数据结构实验之求二叉树后序遍历和层次遍历 (sdut oj2137)

18 篇文章 0 订阅
18 篇文章 0 订阅

数据结构实验之求二叉树后序遍历和层次遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

示例输入

2
abdegcf
dbgeafc
xnliu
lnixu

示例输出

dgebfca
abcdefg
linux
xnuli

提示

 

来源

ma6174

示例程序


#include <bits/stdc++.h>

using namespace std;

int cnt;
char a[1100], b[1100];
struct node
{
    char data;
    node *lchild, *rchild;
} *root;

struct node *creat()
{
    node *root;
    root = new node;
    root->lchild = NULL;
    root->rchild = NULL;
    return root;
}

struct node *build(int low, int high, int _begin)
{
    int flag;
    if(low > high)
        return NULL;
    struct node *root;
    root = creat();
    root->data = a[_begin];
    for(int i = low; i <= high; i++)
    {
        if(a[_begin] == b[i])
        {
            flag = i;
            break;
        }
    }
    root->lchild = build(low, flag-1, _begin+1);
    root->rchild = build(flag+1, high, _begin+flag+1-low);
    return root;
}

void houxu(struct node *root)
{
    if(root)
    {
        houxu(root->lchild);
        houxu(root->rchild);
        printf("%c", root->data);
    }
}

void cengxu(struct node *root)
{
    queue<node *>q;
    q.push(root);
    struct node *ans;
    ans = new node;
    while( !q.empty())
    {
        ans = q.front();
        q.pop();
        if(ans)
        {
            printf("%c", ans->data);
            q.push(ans->lchild);
            q.push(ans->rchild);
        }
    }
}

int main()
{
    int n;
    while(cin >> n)
    {
        while(n--)
        {
            cin >> a;
            cin >> b;
            int l = strlen(a);
            root = build(0, l-1, 0);
            houxu(root);
            cout << endl;
            cengxu(root);
            cout << endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值