Poj 1328 贪心之区间选点+勾股定理**

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 77793 Accepted: 17403

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
 
题意大概为:
  给出一条海岸线作为X轴,将Y轴分成陆地(负半轴)和大海(正半轴),然后在大海里有n个小岛,给出它们的坐标(x, y);
然后用探测范围固定的雷达检测这些小岛,问最少用多少个雷达就能覆盖所有的小岛.
题解思路为:
  通过小岛和雷达的探测范围,找出每一个小岛在X轴上对应的坐标区间,然后把问题转化为区间选点,把得到的区间按照x坐标从小到大排序,然后贪心每个区间最右端的位置点,若下一个区间的左端点比当前的右端点大,则计数加1(cnt++);若下一个区间的右端点小于等于当前的右端点,则将其变成当前的右端点.
注意:
   从做这个题,到最后理解,ac,Wa了十几遍,  一定注意细节!!!


#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdlib>
#include <cstdio>

using namespace std;

struct node
{
    double left, right;
} island[1100];

int cmp(node a, node b)
{
    return a.left < b.left;
}

int main()
{
    int n, k=0;
    double d, x, y;
    while(~scanf("%d%lf", &n, &d), (n!=0&&d!=0))
    {
        k++;
        int flag = 1;
        for(int i = 0; i < n; i++)
        {
            scanf("%lf%lf", &x, &y);
            if(y > d || d < 0)
            {
                flag = 0;
            }
            island[i].left = x-sqrt(d*d-y*y);
            island[i].right = x+sqrt(d*d-y*y);
        }
        if(flag == 0)
        {
            printf("Case %d: -1\n", k);
        }
        else
        {
            int cnt=1;
            sort(island, island+n, cmp);
            double tmp = island[0].right;
            for(int i = 1; i < n; i++)
            {
                if(island[i].left > tmp)
                {
                    cnt++;
                    tmp = island[i].right;
                }
                else if(island[i].right <= tmp)
                {
                    tmp = island[i].right;
                }
            }
            printf("Case %d: %d\n", k, cnt);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯智能台灯

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值