TZOJ 2018: SPF

描述

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.

输入

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

输出

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.


The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

样例输入

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

样例输出

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

 一道模板题,题意大概是求去掉某一割点后图分为几个连通块(分出来的连通块不一定是点双连通分量)如下图

大体思路是用tarjan算法标记所有割点,并统计每个割点被认出过几次。

#include<bits/stdc++.h>
using namespace std;
const int N=1010;
vector<int>g[N];
int dfn[N],low[N],iscut[N],cnt;
void tarjan(int u,int root)
{
    int child=0;
    dfn[u]=low[u]=++cnt;
    for(int i=0;i<g[u].size();i++)
    {
        int v=g[u][i];
        if(!dfn[v])
        {
            tarjan(v,root);
            low[u]=min(low[u],low[v]);
            if(low[v]>=dfn[u])
            {
                child++;
                if(u!=root||u==root&&child>1)//u被判断为割点
                {
                    iscut[u]++;//统计去掉u后可以出现几个子图
                }
            }
        }
        else
        {
            low[u]=min(low[u],dfn[v]);//返祖边
        }
    }
}
int main()
{
    int x,y,pos=0;
    while(scanf("%d",&x),!(x==0))
    {
        cnt=0;
        memset(dfn,0,sizeof(dfn));
        memset(iscut,0,sizeof(iscut));
        for(int i=1;i<N;i++)g[i].clear();
        scanf("%d",&y);
        g[x].push_back(y);
        g[y].push_back(x);
        while(scanf("%d",&x),!(x==0))
        {
            scanf("%d",&y);
            g[x].push_back(y);
            g[y].push_back(x);
        }
        tarjan(1,1);
        if(pos!=0)puts("");
        printf("Network #%d\n",++pos);
        bool flag=false;
        for(int i=1;i<N;i++)
        {
            if(iscut[i])
            {
                printf("  SPF node %d leaves %d subnets\n",i,iscut[i]+1);//最终结果加一
                flag=true;
            }
        }
        if(!flag)cout<<"  No SPF nodes"<<endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值