poj 1981 Circle and Points

Circle and Points

You are given N points in the xy-plane. You have a circle of radius one and move it on the xy-plane, so as to enclose as many of the points as possible. Find how many points can be simultaneously enclosed at the maximum. A point is considered enclosed by a circle when it is inside or on the circle.

Input

The input consists of a series of data sets, followed by a single line only containing a single character ‘0’, which indicates the end of the input. Each data set begins with a line containing an integer N, which indicates the number of points in the data set. It is followed by N lines describing the coordinates of the points. Each of the N lines has two decimal fractions X and Y, describing the x- and y-coordinates of a point, respectively. They are given with five digits after the decimal point.

You may assume 1 <= N <= 300, 0.0 <= X <= 10.0, and 0.0 <= Y <= 10.0. No two points are closer than 0.0001. No two points in a data set are approximately at a distance of 2.0. More precisely, for any two points in a data set, the distance d between the two never satisfies 1.9999 <= d <= 2.0001. Finally, no three points in a data set are simultaneously very close to a single circle of radius one. More precisely, let P1, P2, and P3 be any three points in a data set, and d1, d2, and d3 the distances from an arbitrarily selected point in the xy-plane to each of them respectively. Then it never simultaneously holds that 0.9999 <= di <= 1.0001 (i = 1, 2, 3).

Output

For each data set, print a single line containing the maximum number of points in the data set that can be simultaneously enclosed by a circle of radius one. No other characters including leading and trailing spaces should be printed.

Sample Input3
6.47634 7.69628
5.16828 4.79915
6.69533 6.20378
6
7.15296 4.08328
6.50827 2.69466
5.91219 3.86661
5.29853 4.16097
6.10838 3.46039
6.34060 2.41599
8
7.90650 4.01746
4.10998 4.18354
4.67289 4.01887
6.33885 4.28388
4.98106 3.82728
5.12379 5.16473
7.84664 4.67693
4.02776 3.87990
20
6.65128 5.47490
6.42743 6.26189
6.35864 4.61611
6.59020 4.54228
4.43967 5.70059
4.38226 5.70536
5.50755 6.18163
7.41971 6.13668
6.71936 3.04496
5.61832 4.23857
5.99424 4.29328
5.60961 4.32998
6.82242 5.79683
5.44693 3.82724
6.70906 3.65736
7.89087 5.68000
6.23300 4.59530
5.92401 4.92329
6.24168 3.81389
6.22671 3.62210
0

Sample Output2
5
5
11

题意
半径为1的圆最多能包含几个点。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iomanip>
using namespace std;
const double eps = 1e-10;

int dcmp(double n) {
    if(fabs(n) < eps) return 0;
    else return n > 0 ? 1 : -1;
}

struct Point{
    double x, y;
};

struct node{
    double angle;
    int k;
};

Point p[303];

double dis(Point a, Point  b){
   return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}

bool cmp (node a, node b) {
    if(dcmp(a.angle - b.angle) != 0) return dcmp(a.angle - b.angle) > 0;
    else return a.k < b.k;
}

int main() {
    int n;
    while(scanf("%d", &n) != EOF) {
        if(n == 0) break;
        for (int i = 0; i < n; i++)  scanf("%lf %lf", &p[i].x, &p[i].y);
        
        node a[90003];
        int ans = 0;
        for (int i = 0; i < n; i++) {
            int cnt = 0;
            for(int j = 0; j < n; j++) {
                if(dis(p[i], p[j]) > 2.0) continue;
                double ang1, ang2;
                ang1 = atan2(p[j].y - p[i].y, p[j].x - p[i].x);
                ang2 = acos (dis(p[i], p[j])/ 2);//两点距离的一半除以半径1
                a[cnt].angle = ang1 + ang2, a[cnt++].k = 1;
                 a[cnt].angle = ang1 - ang2, a[cnt++].k = -1;
            }
            int sum = 0;
            sort(a, a + cnt , cmp);
            for(int i = 0; i < cnt; i++) {
                sum += a[i].k;
                ans = max(ans, sum);
            }
        }
        printf("%d\n", ans);
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值