Moo University - Financial Aid POJ - 2010(二分)

Moo University - Financial Aid POJ - 2010

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,“Moo U” for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1…2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university’s limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.

Input

  • Line 1: Three space-separated integers N, C, and F

  • Lines 2…C+1: Two space-separated integers per line. The first is the calf’s CSAT score; the second integer is the required amount of financial aid the calf needs

Output

  • Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.

Sample Input
3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output
35

Hint
ample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.

题意:

有C头牛,每头牛有对应的sorce,aid;
从C头牛里选N头牛,使aid和小于等于F,并且N头牛sorce的中位数最小。

题解:
由于是找中位数,所以自然想到二分的方法。
具体解释看代码。

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
using namespace std;

void optimize_cpp_stdio() {
	ios::sync_with_stdio(false);
    	cout.tie(NULL);
    	cin.tie(NULL);
}

struct Cow {
	int sorce, aid, k;
};

Cow c[100020], b[100020];

bool cmp1 (Cow a, Cow b) {
	 return a.sorce < b.sorce;
}

bool cmp2 (Cow a, Cow b) {
	 return a.aid < b.aid;
}

int main() {
	int N, C, F;
	cin >> N >> C >> F;
	for (int i = 0; i < C; i++) {
		cin >> c[i].sorce >> c[i].aid;
	}
	sort (c, c + C, cmp1);//按照sorce排序,结果如下
	//c的数组
	// 5  20 30 35 50
	// 18 20 25 30 21
	for (int i = 0; i < C; i++) {
		c[i].k = i;
		b[i].k = i;
		b[i].sorce = c[i].sorce;
		b[i].aid = c[i].aid;
	}
	//b的数组
	// sorce: 5 20 50 30 35
	// aid:  18 20 21 25 30
	// 排序:  1  2  5  3  4
	sort (b, b + C, cmp2);
	int ans = 0;
	int l = 0, r = C;
	while (l < r - 1) {
		int mid = (l + r)/2;
		int suml = 0, sumr = 0, sum = c[mid].aid;
		for (int i = 0; i < C; i++) {
			//按照aid排序后,找B[i].k小于mid,也就是找分数在中位数左边的
			if(b[i].k < mid && sum + b[i].aid <= F && suml < N/2) {
				suml++;
				sum = sum + b[i].aid;
			}
			//找右边的
			if(b[i].k > mid && sum + b[i].aid <= F && sumr < N/2) {
				sumr++;
				sum = sum + b[i].aid;
			}
		}
		//如果,中位数左边右边都不到N/2
		//因为suml,sumr如果是一个很小,另一个大于N/2
		//也就是说,min(suml,sum2)的最小情况是一个或者两个>= N/2
		//所以上面的限制中,只可能是 sum + b[i].aid <= F 不满足
		if (suml < N/2 && sumr < N/2) {
			ans = -1;
			break;
		}
		else if(suml < N/2) {
			l = mid;
		}
		else if(sumr < N/2) {
			r = mid;
		}
		else {
          		ans = c[mid].sorce;
          		l = mid;
      		}
	}
	cout << ans << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值