Moo University - Financial Aid (poj 2010 优先队列 或者 二分)

Language:
Moo University - Financial Aid
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5551 Accepted: 1663

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 

Source



题意:从C有奶牛中选N头,给出它们的分数scores和资助aid,要是这N头牛的总资助不超过F,同时它们中分数的中位数最大。求这个最大的中位数。
思路:按照分数排序,枚举每头牛作为中位数,计算牛i前面N/2头牛的最小资助和后面N/2牛的最小资助(用到优先队列)。最后从后往前找第一个满足l[i]+r[i]+cow[i].second<=F的即为答案。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 100005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

priority_queue<int>Q;
int l[maxn],r[maxn];
pair<int,int> cow[maxn];
int n,c,f;

int main()
{
    int i,j;
    while (~sfff(n,c,f))
    {
        FRL(i,0,c)
        sff(cow[i].first,cow[i].second);
        sort(cow,cow+c);
        int half=n/2;
        int sum=0;
        FRL(i,0,c)
        {
            if (Q.size()==half)
                l[i]=sum;
            else
                l[i]=INF;
            sum+=cow[i].second;
            Q.push(cow[i].second);
            if (Q.size()>half)
            {
                sum-=Q.top();
                Q.pop();
            }
        }
        sum=0;
        while (!Q.empty()) Q.pop();
        FREE(i,c-1,0)
        {
            if (Q.size()==half)
                r[i]=sum;
            else
                r[i]=INF;
            sum+=cow[i].second;
            Q.push(cow[i].second);
            if (Q.size()>half)
            {
                sum-=Q.top();
                Q.pop();
            }
        }
        FREE(i,c-1,0)
        {
            if (l[i]+cow[i].second+r[i]<=f)
                break;
        }
        if (i>=0)
            pf("%d\n",cow[i].first);
        else
            pf("-1\n");
    }
    return 0;
}


第二种方法,采用二分:

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 100005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

struct Cow
{
    int s,f;
    int id;
}cow_s[maxn],cow_f[maxn];
int n,f,c,half;

int cmp_s(Cow a,Cow b)
{
    return a.s<b.s;
}

int cmp_f(Cow a,Cow b)
{
    return a.f<b.f;
}

int ok(int mid)
{
    int i,ans;
    int l=0,r=0,sum=cow_s[mid].f;
    FRL(i,0,c)
    {
        if (l<half&&cow_f[i].id<mid&&(sum+cow_f[i].f)<=f)
        {
            l++;
            sum+=cow_f[i].f;
        }
        else if (r<half&&cow_f[i].id>mid&&(sum+cow_f[i].f<=f))
        {
            r++;
            sum+=cow_f[i].f;
        }
    }
    if (l<half&&r<half)
        return -1;
    else if (l<half)
        return 1;
    else if (r<half)
        return 2;
    else
        return 3;
}

void solve(int l,int r)
{
    int mid;
    int ans;
    while (r-l>1)
    {
        mid=(l+r)>>1;
        int flag=ok(mid);
        if (flag==-1)
        {
            ans=-1;
            break;
        }
        else if (flag==1)
            l=mid;
        else if (flag==2)
            r=mid;
        else
        {
            ans=cow_s[mid].s;
            l=mid;
        }
    }
    pf("%d\n",ans);
}

int main()
{
    int i,j;
    while (~sfff(n,c,f))
    {
        FRL(i,0,c)
        sff(cow_s[i].s,cow_s[i].f);
        sort(cow_s,cow_s+c,cmp_s);
        FRL(i,0,c)
            cow_s[i].id=i;
        memcpy(cow_f,cow_s,sizeof(cow_s));
        sort(cow_f,cow_f+c,cmp_f);
        half=n/2;
        solve(0,c);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值