Wireless Network POJ - 2236(并查集)

Wireless Network POJ - 2236

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.

  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output
FAIL
SUCCESS

题意:
给出每个计算机的坐标,每两个计算机距离小于等于d,则可以直接通信。
输入一些操作。
1.“ O p”(1 <= p <= N),表示维修计算机p。
2.“ S p q”(1 <= p,q <= N),表示测试计算机p和q是否可以通信。
在测试的时候,输出p,q是否可以通信。

题解:
x,y是坐标;k是记录父亲节点,pa[]记录可能的每个父亲节点的下标,sum记录父亲节点的个数,f标记有没有维修过

预处理,把每一个点可以通信,即两点间距离小于等于d的用pa记录下来,sum记录个数。每一个点初始都是没有维修过,即fa[i].f = 0;
每次维修的时候,把这个点改成维修过的状态,即fa[i].f = 1,并且遍历和这个点距离小于等于d,即pa[]的点,找到另一个维修好的点,合并。

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
using namespace std;

void optimize_cpp_stdio() {
	ios::sync_with_stdio(false);
    	cout.tie(NULL);
    	cin.tie(NULL);
}

struct D {
	int x, y ,k, f, pa[1010], sum;
};
//x,y是坐标;k是记录父亲节点,pa[]记录可能的每个父亲节点的下标,sum记录父亲节点的个数,f标记有没有维修过
D fa[1010];
int rank[1010];

int find(int x) {
	if(fa[x].k == x) return x;
	else return fa[x].k = find(fa[x].k);
}

void unite (int x, int y) {
	x = find (x);
	y = find (y);
	if(x == y) return ;
	if(rank[x] < rank[y]) fa[x].k = y;
	else  {
		fa[y].k = x;
		if (rank[x] == rank[y]) rank[x]++;
	}
}

bool same(int x, int y) {
	return find(x) == find(y);
}

double dd(int x1, int y1, int x2, int y2){
	return (double)(sqrt((double)(x1-x2)*(x1-x2)+(double)(y1-y2)*(y1-y2)));
}

int main() {
	int N, d;
	cin >> N >> d;
	for (int i = 0; i < N; i++) {
		cin >> fa[i].x >> fa[i].y;
		fa[i].f = 0;//表示没有维修过
		//开始时父亲节点时自己,即fa[i].k = i;
		fa[i].k = i;
		rank[i] = 0;
	}
	//初始化,把任意两点的dd <= d 的 pa都记成该节点的下标
	for (int i = 0; i < N; i++) {
		fa[i].sum = 0;
		for (int j = 0; j < N; j++)
			if(dd(fa[i].x, fa[i].y, fa[j].x, fa[j].y) <= d)
				fa[i].pa[fa[i].sum++] = j; 
			}
	char a;
	int t, s;
	while(cin >> a) {
		if (a == 'O') {
			cin >> t;
			fa[t-1].f = 1;//表示维修过
			for (int i = 0; i < fa[t-1].sum; i++) {
				//只要更新维修过的,把这个点与所有维修过的且距离符合要求的点合并
				if (fa[ fa[t-1].pa[i] ].f == 1)
					unite (fa[t-1].k, fa[ fa[t-1].pa[i] ].k);
			}
		}
		if (a == 'S') {
			cin >> s >> t;
			//查询
			if (same(fa[s-1].k, fa[t-1].k)) cout << "SUCCESS" << endl;
			else cout << "FAIL" << endl;
		}
	}
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值