poj2453

 
An Easy Problem
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3359Accepted: 1772

Description

As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.

For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".

Input

One integer per line, which is I (1 <= I <= 1000000).

A line containing a number "0" terminates input, and this line need not be processed.

Output

One integer per line, which is J.

Sample Input

1
2
3
4
78
0

Sample Output

2
4
5
8
83
这道题花了我好几个小时,开始是编译错误,整了好半天,才知道是pow(x,y);函数的格式不对,
可这也不是我第一次用这个函数啊,以前都是直接(int)pow(x,y);或(long)pow(x,y);就ok了,而
这次居然一定要写成(int或long)pow((double)x,y);,寒!!!!!!
后来就是wrong answer了,很奇怪,发现有些测试数据第一次输入是正确的,而第二次就错了,
后来听同学提示,才明白,是在一组数据测试完后,测试第二组的时候,有一些变量没有初始
化。
 
代码写的不好,不过AC了,希望路过的牛人不要吝惜一些好的方法:
 
#include<stdio.h>
#include<math.h>
int main()
{
 long m,i,j,t,s,res,num[50],tag[50]={0};
    while(scanf("%ld",&m))
 {                         
  for(i=0;i<50;i++)
  {
   tag[i]=0;
   num[i]=0;
  }
  if(m==0)
   break;
  for(i=0;;i++)
  {
   num[i]=(long)pow((double)2,i);
   if(m<(long)pow((double)2,i+1)&&m>=num[i])
   {
    t=i;
    break;
   }
  }
  for(i=t;i>=0;i--)
  {
   if(m-num[i]>=0)
   {
       tag[i]=1;
    m=m-num[i];
   }
   else
    tag[i]=0;
  }
  for(i=0;i<=t;i++)
  {
   if(tag[i]==0)
    s=0;
   else
    s=1;
   if(tag[i+1]==0&&s==1)
   {
    tag[i+1]=1;
    tag[i]=0;
    if(i==t)
     t++;
    break;
   }
   else if(tag[i+1]==1&&s==0)
   {
    if(i==t-1)
    {
     t++;
     tag[t]=1;
     tag[t-1]=0;
     break;
    }
    else
    {
     while(tag[++i]==1)
     {
      if(tag[i+1]==0)
       break;
     }
     if(i==t)
     {
      t++;
         tag[t]=1;
                        tag[t-1]=0;
      for(j=0;j<=t-2;j++)
      {
       if(tag[j]==0&&tag[t-2-j]==1&&t-2-j>j)
       {
        tag[j]=1;
        tag[t-2-j]=0;
       }
      }
         break;
     }
     else
     {
      tag[i]=0;
      tag[i+1]=1;
      for(j=0;j<=i-1;j++)
      {
       if(tag[j]==0&&tag[i-1-j]==1&&i-1-j>j)
       {
        tag[j]=1;
        tag[i-1-j]=0;
       }
      }
      break;
     }
    }
   }
  }
  res=0;
  for(i=0;i<=t;i++)
  {
   if(tag[i]==1)
      res=res+(long)pow((double)2,i);
  }
  printf("%ld/n",res);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值