相似三角形

Problem Description

给出两个三角形的三条边,判断是否相似。

Input

多组数据,给出6正个整数,a1,b1,c1,a2,b2,c2,分别代表两个三角形。(边长小于100且无序

Output

如果相似输出YES,如果不相似输出NO,如果三边组不成三角形也输出NO。

Example Input
1 2 3 2 4 6
3 4 5 6 8 10
3 4 5 7 8 10
Example Output
NO
YES
NO
Hint
 
Author
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		while(in.hasNext()){
			 int a1 = in.nextInt();
	            int b1 = in.nextInt();
	            int c1 = in.nextInt();
	            int a2 = in.nextInt();
	            int b2 = in.nextInt();
	            int c2 = in.nextInt();
			Tir cc = new Tir(a1,b1,c1,a2,b2,c2);
			cc.show();
		}
	}
}
class Tir{
	 int a1;
     int b1;
     int c1;
     int a2;
     int b2;
     int c2;
	public Tir(int a1,int b1,int c1,int a2,int b2,int c2){
		this.a1 = a1;
		this.b1 = b1;
		this.c1 = c1;
		this.a2 = a2;
		this.b2 = b2;
		this.c2 =c2;
	}
	public void show(){
		int temp;
		 if(a1<b1) {
             temp = a1;
             a1 = b1;
             b1 = temp;
         }
         if(a1<c1) {
             temp = a1;
             a1 = c1;
             c1 = temp;
         }
         if(b1<c1) {
             temp = b1;
             b1 = c1;
             c1 = temp;
         }

         if(a2<b2) {
             temp = a2;
             a2 = b2;
             b2 = temp;
         }
         if(a2<c2) {
             temp = a2;
             a2 = c2;
             c2 = temp;
         }
         if(b2<c2) {
             temp = b2;
             b2 = c2;
             c2 = temp;
         }
         if((b1+c1>a1) && (b2+c2>a2)) {
             if((a1*b2==a2*b1) && (a1*c2==a2*c1) &&(b1*c2==b2*c1)) {
                 System.out.println("YES");
             } else {
                 System.out.println("NO");
             }
         } else {
             System.out.println("NO");
         }
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值