POJ3061尺取法)

Subsequence

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 10657

Accepted: 4418

Description

A sequence of Npositive integers (10 < N < 100 000), each of them less than or equal10000, and a positive integer S (S < 100 000 000) are given. Write a programto find the minimal length of the subsequence of consecutive elements of thesequence, the sum of which is greater than or equal to S.

Input

The first line isthe number of test cases. For each test case the program has to read thenumbers N and S, separated by an interval, from the first line. The numbers ofthe sequence are given in the second line of the test case, separated byintervals. The input will finish with the end of file.

Output

For each the casethe program has to print the result on separate line of the output file.if noanswer, print 0.

Sample Input

2

10 15

5 1 3 5 10 7 4 9 2 8

5 11

1 2 3 4 5

Sample Output

2

3

题目基本上只这样的,给定长度为n的数列整数a0,a1…..an-1以及整数S。求出总和不小于S的连续子序列的长度的最小值。如果不存在输出0。

比如第一组数据5+10长度为二,第二组数据3+4+5长度为三。



 
思路: 求sum值之后排序用尺取法

#include<iostream>
using namespace std;
#define maxn 100005
int a[maxn];
int main(void)
{
	int cas,s,n;
	cin>>cas;
	while(cas--)
	{
		cin>>n>>s;
		for(int i=0;i<n;i++)
		cin>>a[i];
		int i=0,sum=0,ans=n+1,j=0;
		while(1){
			while(j<n&&sum<=s)
			sum+=a[j++];
			if(sum<s)
			break;
			ans=min(j-i,ans);
			sum-=a[i++]; 
		}
		if(ans>n)
		ans=0;
		cout<<ans<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值