【PAT】1063. Set Similarity (25)

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%

分析:两个集合共有的元素个数 / 两个集合合并后的元素个数.

有一组超时,待改进:

#include<iostream>
#include<set>
#include<vector>
using namespace std;
int main()
{
	int N;	
	int i,count,j,t;
	cin>>N;
	vector< set<int> > vec(N);
	for(i=0; i<N; i++){
		scanf("%d",&count);
		for(j=0; j<count; j++){
			scanf("%d",&t);
			vec[i].insert(t);
		}
	}
	int request,a,b;
	scanf("%d",&request);
	for(i=0; i<request; i++){
		scanf("%d %d",&a,&b);
		set<int> temp_set;
		set<int>::iterator it;
		for(it = vec[a-1].begin(); it != vec[a-1].end(); it++){
			temp_set.insert( *it );
		}
		for(it = vec[b-1].begin(); it != vec[b-1].end(); it++){
			temp_set.insert( *it );
		}
		
		printf( "%.1f",(float)( vec[a-1].size()+vec[b-1].size()-temp_set.size())*100/(float)(temp_set.size()) );
		cout<<"%"<<endl;
	}
	return 0;
}


改进后如下,可以通过:

#include <iostream>
#include <vector>
#include <set>
using namespace std;
#define MAX 1000000001

int main(int argc, char** argv) {
	int n, m, i, j, t;
	scanf("%d",&n);
	vector< set<int> > vec(n+1);
	for(i=1; i<=n; i++){
	  	scanf("%d",&m);
		for(j=0; j<m; j++){
	  		cin>>t;			 
			vec[i].insert(t);	
		}
	}
	
	int query, a, b;
	scanf("%d",&query);
	for(i=0; i<query; i++){
		scanf("%d%d",&a,&b);	 
		int total = vec[a].size() + vec[b].size();
		int num = total;
		for(set<int>::iterator it=vec[a].begin(); it!=vec[a].end(); it++){
			if(vec[b].count(*it)==1){
				num--;
			}
		}
		printf("%.1lf%\n", (double)(total-num) /(double)num * 100);
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值