1007 Maximum Subsequence Sum (25 分) Java实现

1007 Maximum Subsequence Sum (25 分) Java实现

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains Knumbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:给定一个序列,找出最大和序列,并输出最大和,序列首尾的数。

解题思路:设置一个临时的和temp,初始化为0,它的下标为tempindex,当temp < 0,那么后面不管来什么值,都应该舍弃temp < 0前面的内容,因为负数对于总和只可能拉低总和,不可能增加总和,还不如舍弃,舍弃后,直接令temp = 0,并且同时更新left的临时值tempindex。如果temp>sum,则更新sum,left,right值。如果序列所有值都为负数,因为sum初始化为-1,判断sum<0,更新sum=0。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;
public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader in=new BufferedReader(new InputStreamReader(System.in));
        String n=in.readLine();
        int k=Integer.parseInt(n);
        int temp=0;
        int tempindex=0;
        int  left=0;
        int right=k-1;
        int sum=-1;
        String []s=in.readLine().split(" ");
        int a[]=new int [k];
        for(int i=0;i<k;i++){
            a[i]=Integer.parseInt(s[i]);
            temp=temp+a[i];
            if(temp>sum){
                sum=temp;
                left=tempindex;
                right=i;
            }else if(temp<0){
                temp=0;
                tempindex=i+1;
            }
        }
        if(sum<0){
            sum=0;
        }
        System.out.println(sum+" "+a[left]+" "+a[right]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值