PAT-Java-First Contact (30)

First Contact

题目阐述

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0


题目分析

初看到这一道题,一下子想起之前看过的一道面试经验题,找出A和B所有的共同微信好友,但是这道题比那道还是麻烦了许多,网上搜解法,发现了柳婼 の blog,她在这篇博客里给出了非常便捷的解法,具体想了解的可以看下她的主页,不过这让我发现了这位大神,看完了她的许多刷题记录,只想奉上膝盖先。下面是转载过来的她的分析以及我修改丢丢后的代码;

  1. 用数组arr标记两个人是否是朋友(邻接矩阵表示),用v标记所有人的同性朋友(邻接表表示)
  2. 对于一对想要在一起的A和B,他们需要先找A的所有同性朋友C,再找B的所有同性朋友D,当C和D两人是朋友的时候则可以输出C和D
  3. A在寻找同性朋友时,需要避免找到他想要的伴侣B,所以当当前朋友就是B或者B的同性朋友就是A时舍弃该结果
  4. 输出时候要以4位数的方式输出,所以要%04d
  5. 如果用int接收一对朋友,-0000和0000对于int来说都是0,将无法得知这个人的性别,也就会影响他找他的同性朋友的那个步骤,所以考虑用字符串接收,因为题目中已经表示会以符号位加四位的方式给出输入,所以只要判断字符串是否大小相等,如果大小相等说明这两个人是同性
  6. 结果数组因为必须按照第一个人的编号从小到大排序(当第一个相等时按照第二个人编号的从小到大排序),所以要用sort对ans数组排序后再输出结果

提交代码

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>

using namespace std;

struct node {
    int a, b;
};

bool cmp(node n1, node n2) {
    return n1.a != n2.a ? n1.a < n2.a : n1.b < n2.b;
}

bool arr[10000][10000];

int main() {
    int n, m, l, r;
    cin >> n >> m;
    vector<int> v[10000];
    string a, b;

    for (int i = 0; i < m; i ++) {
        cin >> a >> b;
        l = abs(stoi(a)), r = abs(stoi(b));
        arr[l][r] = true;
        arr[r][l] = true;
        if (a.length() == b.length()) {
            v[l].push_back(r);
            v[r].push_back(l);
        }
    }

    int q;
    cin >> q;
    for (int i = 0; i < q; i++) {
        cin >> l >> r;
        l = abs(l), r = abs(r);
        vector<node> temp;
        for (int i = 0; i < v[l].size(); i++) {
            for (int j = 0; j < v[r].size(); j++) {
                if (v[l][i] == r || l == v[r][j]) continue;
                if (arr[v[l][i]][v[r][j]] == true)
                    temp.push_back(node{ v[l][i], v[r][j] });
            }
        }
        printf("%d\n", temp.size());
        sort(temp.begin(), temp.end(), cmp);
        for (node n : temp) {
            printf("%04d %04d\n", n.a, n.b);
        }
    }
    return 0;
}

总结

  1. 首次第一次在同一个题里使用邻接矩阵和邻接表;
  2. stoi函数可以直接将string转为int型数据;
  3. 存储所有信息时充分利用空间换时间,如所有人员总数不超过300, 而且每个人的序号在4位数内,这意味着可以直接将其序号作为二维数组的索引,省去构建map的繁琐过程,虽然那样节省了空间;
  4. 邻接表构建时,利用vector[10000]数组,一开始我少打了一个0,结果重新提交了好多次,我甚至想到其实只要300就足够了把,但这里依然是耗费一部分内存换来了极快的时间,再次拜服;
  5. 再次复习了结构体的知识,定义一个结构体并利用其构建一个实例;
  6. 调用了sort排序函数时,默认从小到大输出,所以实现cmp函数时候需注意不要把顺序搞混了;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值