A + B Problem II (大数加模拟,,坑点在格式错误)

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

格式错误的坑就是在最后一个没有  回车

还要注意初始化!!!!

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int a[1005],b[1005],ans[1005];
int lena=0,lenb=0,Len=0;
void mult(string s1,string s2){
    for(int i=s1.length()-1 ;i>=0;i--){//将数逆转 
    	a[lena]=s1[i]-'0';
    	lena++;
	}
    for(int i=s2.length()-1 ;i>=0;i--){
    	b[lenb]=s2[i]-'0';
    	lenb++;
	}
	if(lena>lenb){
        Len=lena;
	}
	else{
		Len=lenb;
	}
	for(int i=0;i<Len;i++){
		ans[i]+=a[i]+b[i];//原来的进位加上又新加出来的 
		ans[i+1]+=ans[i]/10;//把进位添到上一位去 
		ans[i]=ans[i]%10;//除去进位 
	}
	bool flag=true;
	for(int i=Len;i>=0;i--){
		if(ans[i]!=0||!flag){  
			flag=false;
			cout<<ans[i];
		}
	} 
	cout<<endl;
}
void Inti(){
	lena=0,lenb=0,Len=0;
	memset(a,0,sizeof(a));
	memset(b,0,sizeof(b));
	memset(ans,0,sizeof(ans));
}
int main(){
	int t;
	cin>>t;
	getchar();
	for(int i=1;i<=t;i++){
		string s1,s2;
        cin>>s1>>s2;
        getchar();
        cout<<"Case "<<i<<":"<<endl; 
        cout<<s1<<" + "<<s2<<" = ";
        Inti();
	    mult(s1,s2);
	    if(i!=t) 
	        cout<<endl;
	} 
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值