A+BProblemII

题目描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
大数相加,int,long long,unsigned long long存不下,需要用字符串存,每个字符相加,大于9,进1;思路可能不太清楚,看代码理解把. 如果没有理解可以评论,我在详细讲解.

    #include<stdio.h>
    #include<string.h>
    int main()
    {
    	int a;
    	scanf("%d",&a);
    	int p = 1;
    	while(a--)
    	{
    		char q[100000],w[100000];
    		int e[100000] = {0},r[100000] = {0},t[100000] = {0},y[100000] ={0};
    		scanf("%s%s",q,w);
    		int z = strlen(q),x = strlen(w);
    		for(int i = z - 1 , j = 0 ; i >= 0 && j < 100000; i-- , j++)
    		{
    			t[j] = e[j] = q[i] - '0';//把每个数字存在数组里; 
    		}
    		for(int i = x - 1 , j = 0 ; i >= 0 && j < 100000; j++ , i--)
    		{
    			y[j] = r[j] = w[i] - '0';//把每个数字存在数组里; 
    		}
    		printf("Case %d:\n",p);
    		for(int i = z - 1 ; i >= 0 ; i--)
    		{
    			printf("%d",t[i]);
    		}
    		printf(" + ");
    		for(int i = x - 1 ; i >= 0 ; i--)
    		{
    			printf("%d",y[i]);
    		}
    		printf(" = ");
    		for(int i = 0 ; i < 100000 ; i++)
    		{
    			e[i] = e[i] + r[i];
    			if(e[i] > 9)//如果大于9,减10,然后把减10后的数字存入数组中,然后让下一个数组中存得数字加1,这样就做到了进1.
    			{
    				e[i] = e[i] - 10;
    				e[i + 1]++;
    			}
    		}
    		int i;
    		for( i = 99999 ; i >= 0 ; i--)
    		{
    			if(e[i] != 0 || r[i] != 0)//找到第一个不等于0得i值,然后从i值往后输出.
    			{
    				break;
    			}
    		}
    		for(;i >= 0 ; i--)
    		{
    			printf("%d",e[i]);
    		}
    		printf("\n");
    		p++;
    	}
    }



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值