Nuanran's Idol II

You have known that nuanran is a loyal fan of Kelly from the last contest. For this reason, nuanran is interested in collecting pictures of Kelly. Of course, he doesn't like each picture equally. So he gives each picture a score which is a positive integer. And the larger the score is, the more he likes that picture. Nuanran often goes to buy new pictures in some shops to increase his picture collection.

Sometimes nuanran's friends ask him for Kelly's picture and he will choose the picture having the smallest score. Because he has many pictures, this is a boring task. Can you help him again?

Input

For each test case, the first line gives an integer n (1 ≤ n ≤ 100000). Then n lines follow, each line has one of the following two formats.

  • "B S". Denoting nuanran buys a new picture and S is the score of that picture.
  • "G". Denoting nuanran gives a picture to his friends.

The input is terminated when n=0.

Output

For each giving test case, you should output the score of the picture nuanran gives to his friends.

Sample Input

8
B 20
B 10
G
B 9
G
B 100
B 25
G
0

 

Sample Output

 

10
9
20

TOJ 2196

每次输入G时,输出最小的数字,并将它从已有数字中删除, n=100000,不能超时

sort函数复杂度n*lg(n)超时

set的inset复杂度为lg(n);但set只能通过迭代器来访问,不能像数组下标那样(vector可以)

find(value)  erase(value)复杂度为lg(n)  ,clear()为o(n)

#include<iostream>
#include<set>//内部自动有序从小到大,且不含重复元素
using namespace std;
int main()
{
    int n,s;
    char b;
    while(cin>>n&&n>0){
        //vector<int> temp;
        multiset<int> ans;//不去重
        //set<int>::iterator it;
        while(n--){
            cin>>b;
            if(b=='B'){
                cin>>s;
                ans.insert(s);
            }
            if(b=='G'){
                cout<<*(ans.begin())<<endl;
                ans.erase(ans.begin());
            }
        }
        ans.clear();
    }
    return 0;
}


从网上抄的
#include<iostream>
#include<deque>
#include<set>
using namespace std;
int main()
{
    multiset<int>IntSet1;//默认由小到大排列
    deque<int>IntSet2;   //可以先进先出
    int T;
    while(cin>>T&&T>0)
    {
         char flag;       //判断输入的是B还是G
         int  temp;        //临时变量
         for(int i=0;i<T;++i)
         {
               cin>>flag;    //输入字符
               //若为B,则输入temp,同时将temp插入IntSet1
               if(flag=='B'){cin>>temp;IntSet1.insert(temp);}
               //若为G,则将IntSet1中最小的那个数插入IntSet2中,同时擦除IntSet1中该元素
               else if(flag=='G'){IntSet2.push_back(*IntSet1.begin());IntSet1.erase(IntSet1.begin());}
         }
         IntSet1.clear();  //清空IntSet1
         deque<int>::iterator pos;   //定义一个迭代器
         for(pos=IntSet2.begin();pos!=IntSet2.end();++pos)
               cout<<*pos<<endl;       //输出
         IntSet2.clear();    //清空IntSet2
    }
    return 0;
}
*/
/*
以下试错
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
    int n,k;
    char b;
    while(cin>>n&&n){
     vector<int> a;
     while(n--){
        cin>>b;
        if(b=='B'){
            cin>>k;
            a.push_back(k);
        }
         if(b=='G'){
            sort(a.begin(),a.end());
            cout<<a[0]<<endl;
           a[0]=100000;
        }
     }
    }
    return 0;
}

*/


/*
const int maxnum=1000000000;
int main()
{
      int n;
      char b;
      int num=0;
      while(cin>>n&&n){
          while(n--){

            cin>>b;
            if(b=='B'){
              cin>>a[num];
              num++;
          }
          else if(b=='G'){
              int min=a[0];
              int j;
              for(int i=1;i<num;i++)
                  if(min>a[i]){
                    min=a[i];
                    j=i;
                  }
               cout<<min<<endl;
                a[j]=maxnum;
          }
        }
      }
      return 0;
}
*/
 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值