Couples 夫妻配对

Description

N couples are standing in a circle, numbered consecutively clockwise from 1 to 2N. Husband and wife do not always stand together. We remove the couples who stand together until the circle is empty or we can't remove a couple any more.

Can we remove all the couples out of the circle?

Input

There may be several test cases in the input file. In each case, the first line is an integer N(1 <= N <= 100000)----the number of couples. In the following N lines, each line contains two integers ---- the numbers of each couple.
N = 0 indicates the end of the input.

Output

Output "Yes" if we can remove all the couples out of the circle. Otherwise, output "No".

Sample Input
 Copy sample input to clipboard
4
1 4
2 3
5 6
7 8

2
1 3
2 4

0
Sample Output
Yes
No

Problem Source: ZSUACM Team Member

我的解法:
#include <stack>
#include <iostream>
#include <vector>

using namespace std;

int main()
{

int n;         //共有几对夫妻
while(cin>>n){   //读取每组测试数据中夫妻的对数
if(n==0) return 0;  //读到0测试数据结束
int a,b;           //接受数据
vector<int> cou;    //接受夫妻数据向量,其中向量下标为夫妻的序号减一
stack<int> cirl;   //用栈来验证是否都符合要求
vector<int>::iterator it;
for(int z=0;z<n*2;z++) //初始化向量
{
cou.push_back(z);
}

for(int x=0;x<n;x++)  //读取每对夫妻
{
cin>>a>>b;        
a=a-1;
b=b-1;
cou[a]=x;       //每对夫妻在向量中的数值相同
cou[b]=x;
}

for(it=cou.begin();it!=cou.end();it++)
{
if(!cirl.empty())
{
if(cirl.top()==(*it))  //数值相同,为夫妻,栈顶数据移除
{
cirl.pop();       
}
else cirl.push(*it);   //如果不相同,则入栈,查找下一个
}
else cirl.push(*it); 
}
if(!cirl.empty())           //栈为空则符合题目要求
cout<<"No"<<endl;
else cout<<"Yes"<<endl;
}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值