To and Fro简单加密

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There's no place like home on a snowy night" and there are five columns, Mo would write down t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character `x' to pad the message out to make a rectangle, although he could have used any letter. Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as toioynnkpheleaigshareconhtomesnlewx Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input
 Copy sample input to clipboard
5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0
Sample Output
theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

我的解法:

#include <iostream>
#include <string>


using namespace std;


int main()
{
int num;
while(cin>>num)
{
if(num == 0)
return 0;
string contact;   //接收字符串
cin>>contact;
int state=0;      //从0开始记录数组的行数
int t=0,heigh;    //t是循环判断,heigh记录该数组的总行数
int c=0;   //记录字符串位置
t=contact.size()/num;
heigh=t;
char a[100][20];   //一个最坏情况下需要数组最大空间
while(t!=0)
{
if(state%2==0)        //判断正向还是逆向记录字母到数组
{
for(int i=0;i<num;i++)
{
a[state][i]=contact[c];
c++;
}
}
if(state%2!=0)
{
for(int j=num-1;j!=-1;j--)
{
a[state][j]=contact[c];
c++;
}
}
state++;    //开始新的一行
t--;        
}
for(int k=0;k<num;k++)     //按要求输出
for(int z=0;z<heigh;z++)
{
cout<<a[z][k];
}
cout<<endl;
}
return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值