ubuntu apache apxs 安装问题

转载 2011年10月18日 16:35:08

ubuntu apache apxs 安装问题

转自: http://blog.csdn.net/wjy9772/article/details/3219264

分类: linux 552人阅读 评论(0) 收藏 举报
采用 sudo apt-get install apache 安装apache服务,不会自带apxs(apache extension tool [apache扩展模块的工具,例如$apxs -i -a -c mod_foo.c]),需安装 apache-dev


wangjinyang@wjy-ubuntu:~$ sudo apt-get install apache
apache                  apache2-mpm-itk         apache-common
apache2                 apache2-mpm-perchild    apache-dbg
apache2.2-common        apache2-mpm-prefork     apache-dev
apache2-common          apache2-mpm-threadpool  apache-doc
apache2-dev             apache2-mpm-worker      apache-modules
apache2-doc             apache2-prefork-dev     apache-perl
apache2-modules         apache2-src             apache-ssl
apache2-mpm             apache2-threaded-dev    apachetop
apache2-mpm-event       apache2-utils           apache-utils
wangjinyang@wjy-ubuntu:~$ sudo apt-get install apache-dev
[sudo] password for wangjinyang:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
将会安装下列额外的软件包:
  libdb4.4-dev libexpat1-dev
建议安装的软件包:
  apache-ssl apache-perl db4.4-doc
下列【新】软件包将被安装:
  apache-dev libdb4.4-dev libexpat1-dev
共升级了 0 个软件包,新安装了 3 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 1014kB 的软件包。
操作完成后,会消耗掉 2818kB 的额外磁盘空间。
您希望继续执行吗?[Y/n]Y
获取:1 http://ubuntu.csie.ntu.edu.tw hardy/main libexpat1-dev 2.0.1-0ubuntu1 [134kB]
获取:2 http://fr.archive.ubuntu.com feisty/universe apache-dev 1.3.34-4.1 [333kB]
获取:3 http://ubuntu.csie.ntu.edu.tw hardy/universe libdb4.4-dev 4.4.20-11 [547kB]
下载 1014kB,耗时 60s (16.7kB/s)                                               
选中了曾被取消选择的软件包 libexpat1-dev。
(正在读取数据库 ... 系统当前总共安装有 104434 个文件和目录。)
正在解压缩 libexpat1-dev (从 .../libexpat1-dev_2.0.1-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 libdb4.4-dev。
正在解压缩 libdb4.4-dev (从 .../libdb4.4-dev_4.4.20-11_i386.deb) ...
选中了曾被取消选择的软件包 apache-dev。
正在解压缩 apache-dev (从 .../apache-dev_1.3.34-4.1_all.deb) ...
正在设置 libexpat1-dev (2.0.1-0ubuntu1) ...

正在设置 libdb4.4-dev (4.4.20-11) ...
正在设置 apache-dev (1.3.34-4.1) ...
wangjinyang@wjy-ubuntu:~$

默认位置:usr/bin/apxs


注:ubuntu11已经是usr/bin/apxs2


ubuntu apt-get install apache2之后没有apxs2的解决

为了图省事,我直接在自己的小u上apt-get install apache2 装上了apache 装完之后发现没有apx2,查了下发现apxs2是在apache-dev里面的,于是 apt-get ...
  • jlnuboy
  • jlnuboy
  • 2010-03-07 15:40:00
  • 1642

apache2中没有apxs

在我的实验机(lubuntu16.04)中,发现并没有apxs这个东西,那我们应该怎么来安装它呢? 很简单,使用下面的命令: sudo apt-get install apache2-dev然后在...
  • Mr_Pang
  • Mr_Pang
  • 2016-06-16 20:55:26
  • 2833

ubuntu16.04安装配置mod_python,apxs,apache

安装配置mod_python,apxs,apache
  • Nicholas_Wong
  • Nicholas_Wong
  • 2017-05-01 19:22:17
  • 643

Apache apxs 扩展工具的安装

在F13下,默认安装的apache httpd服务是没有安装httpd的开发包,所以,大家在查找apxs扩展工具的时候,经常找不到默认的安装位置。比如,在编译安装PHP的时候,可能需要指定’–with...
  • CHEGKN
  • CHEGKN
  • 2015-05-24 13:15:21
  • 4565

使用apxs安装apache模块

使用apxs安装apache模块                 -——by石锅拌饭 1.缘由 前几天迁移系统,发现配置了fastcgi的一个脚本下载文件总是提示类似Connection rese...
  • ssjhust123
  • ssjhust123
  • 2014-10-12 22:54:08
  • 2646

linux 系统下apache 找不到apxs 文件等

在安装   linux 系统是顺便把apache 服务装好了 ,这时这是装了一个服务不能进行二次开发, 所以很多的开发工具和文件在apache下找不到,比如模块编译工具apxs ,这时就要求安装 开...
  • studypower
  • studypower
  • 2013-02-25 18:10:10
  • 2894

window环境下apache模块开发工具apxs及安装使用详细说明

  • 2012年11月23日 13:35
  • 27.72MB
  • 下载

Windows使用apxs独立编译 Apache 模块

下载 apxs http://www.apachelounge.com/download/ 安装 apxs 1.解压apxs.zip,如C:\apxs 2.打开命令提示符,切换当前目录到解...
  • studypower
  • studypower
  • 2013-02-25 22:54:49
  • 3046

windows下开发apache模块环境部署(apache,perl,apxs)

1,windows下安装apache 地址:http://apache.dataguru.cn//httpd/binaries/win32/  一定要custom全部安装,否则就不会有includ...
  • xing_anksh
  • xing_anksh
  • 2014-02-24 18:01:20
  • 2822

ubuntu mono apache mysql 安装指南

  • 2015年01月19日 17:03
  • 2.65MB
  • 下载
收藏助手
不良信息举报
您举报文章:ubuntu apache apxs 安装问题
举报原因:
原因补充:

(最多只允许输入30个字)