hdu 2690 Choose the best route (bellman_ford)

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5044    Accepted Submission(s): 1602


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

Author
dandelion
 


解题报告:对bellman_ford算法还是不太熟悉,又写了一遍,大致的实现过程倒是知道,和dijkstra算法相比,一个是往深度进行搜所,一个是往广度进行,大致的理解是这样的,只是对于非负边来说。对于本题来说,给出好多的出发点,但是只有一个终点,我们可以考虑逆向求解,设只有一个起点,到其他点的单源最短路就很容易求解了,所以我在输入的时候改变了每条边的起点和终点的位置;


代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 0x7ffffff;
int n,m,e,min;
int mp[1005][1005],s[1005],dis[20005];
struct station
{
	int p,q,t;
}st[20005];

void init()
{
	for(int i=1;i<=n;i++)
		for(int j=i;j<=n;j++)
		{
			mp[i][j]=mp[j][i]=maxn;
		}
}

void bellman_ford()
{

	for(int i=1;i<=n;i++)
		dis[i]=maxn;
	dis[e]=0;
	for(int i=1;i<n;i++)
		for(int j=1;j<=m;j++)
			if(dis[st[j].q] > dis[st[j].p]+st[j].t)
				dis[st[j].q] = dis[st[j].p]+st[j].t;
}

int main()
{
	int w;
	while(scanf("%d%d%d",&n,&m,&e)!=EOF)
	{
		init();
		for(int i=1;i<=m;i++)
			scanf("%d%d%d",&st[i].q,&st[i].p,&st[i].t);
		scanf("%d",&w);
		for(int i=1;i<=w;i++)
			scanf("%d",&s[i]);
		bellman_ford();
		min=maxn;
		for(int i=1;i<=w;i++)
			if(min>dis[s[i]])
				min=dis[s[i]];
		printf("%d\n",min==maxn?-1:min);
	}
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值