1016 Phone Bills (25分)

1016 Phone Bills (25分)

A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.
For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

解题思路:

1、据输入要求,给出名字、时间、状态 ,输出每个人的通话时间片、时间长度、总费用。要根据每个人的名字填入数据,可以容易想到用map 作string 与时间、状态之间的映射。

map<string,vector<Date> > users;

2、每个人的通话时间要按照要求从小到大排序。因此用建立一个数据结构,存放一个人的所有通话时间,以及每个通话时间的状态

struct Date{
    int month,dd,hh,mm;
    int tag;
}date;

排序函数:

bool cmp(Date a,Date b){
    if(a.month!=b.month) return a.month<b.month;
    else if(a.dd!=b.dd) return a.dd<b.dd;
    else if(a.hh!=b.hh) return a.hh<b.hh;
    else return a.mm<b.mm;
}

3、从有序数组中找出成对的通话记录,并计算费用。我用最简单的方法计算的通话费用,一分钟一分钟的数数,直到起始日期加到了目标日期。每次数到60分钟时,计算m(记录数了多少分钟)与当前小时值所对用的费用的乘积,将小时值加一并将分钟数与m置零。

int charge[24]={0};
int getprice(Date _begin,Date _end){
    int ans=0,m=0;
    while(_begin.dd<_end.dd||_begin.hh<_end.hh||_begin.mm<_end.mm){
        m++;_begin.mm++;
        if(_begin.mm==60){
            ans+=m*charge[_begin.hh];
            _begin.mm=0;
            _begin.hh++;
            m=0;
        }
        if(_begin.hh==24){
            _begin.hh=0;
            _begin.dd++;
        }
    }
    ans+=m*charge[_begin.hh];
    return ans;
}

AC代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
int charge[24]={0};
struct Date{
    int month,dd,hh,mm;
    int tag;
}date;

bool cmp(Date a,Date b){
    if(a.month!=b.month) return a.month<b.month;
    else if(a.dd!=b.dd) return a.dd<b.dd;
    else if(a.hh!=b.hh) return a.hh<b.hh;
    else return a.mm<b.mm;
}
int n,x;
int getprice(Date _begin,Date _end){
    int ans=0,m=0;
    while(_begin.dd<_end.dd||_begin.hh<_end.hh||_begin.mm<_end.mm){
        m++;_begin.mm++;
        if(_begin.mm==60){
            ans+=m*charge[_begin.hh];
            _begin.mm=0;
            _begin.hh++;
            m=0;
        }
        if(_begin.hh==24){
            _begin.hh=0;
            _begin.dd++;
        }
    }
    ans+=m*charge[_begin.hh];
    return ans;
}
int main(){
    map<string,vector<Date> > users;
    for(int i=0;i<24;i++)
        cin>>charge[i];
    cin>>n;
    string name,temp;
    for(int i=0;i<n;i++){
        cin>>name;
        scanf("%d:%d:%d:%d",&date.month,&date.dd,&date.hh,&date.mm);
        cin>>temp;
        if(temp=="on-line")
            date.tag=0;
        else
            date.tag=1;
        users[name].push_back(date);

    }
    for(map<string,vector<Date> >::iterator it=users.begin();it!=users.end();it++){
        sort(it->second.begin(),it->second.end(),cmp);
        vector<Date> temp=it->second;
        bool flag=0;
        int ans=0;
        for(int i=0;i<temp.size();i++){
            if(temp[i].tag==0){
                int j=i+1;
                while(j<temp.size()&&temp[j].tag!=1){i++;j++;}
                if(j<temp.size()){
                    if(!flag){printf("%s %02d\n",it->first.c_str(),temp[i].month);}
                    int p=getprice(temp[i],temp[j]);
                    ans+=p;
                    int d=temp[j].dd-temp[i].dd;
                    int h=temp[j].hh-temp[i].hh;
                    int m=temp[j].mm-temp[i].mm;
                    if(m<0){m+=60;h--;}
                    if(h<0){h+=24;d--;}
                    printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",temp[i].dd,temp[i].hh,temp[i].mm,temp[j].dd,temp[j].hh,temp[j].mm,d*24*60+h*60+m,(double)p/100);
                    flag=1;
                }

            }
        }
        if(flag){
            printf("Total amount: $%.2f\n",(double)ans/100);
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值