myeclipse10下 Java compiler level does not match解决方法

以前一直用myeclipse2014,忽然换到myeclipse10,很多项目到这里运行起来老是出问题,得总结啊。
compiler是编译的意思,在项目导入IDE的时候,自己选择编译器,编译器会构建ide的环境

并把这个编译的一些参数放入IDE工作空间下面的项目文件下面有一个setting文件夹,里面的org.eclipse.wst.common.project.facet.core.xml 文件的参数
形如:

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="java" version="1.5"/>
  <installed facet="jst.web" version="2.5"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

这里的1.5就是你编译的版本。java的虚拟机是一种解释行的语言,那么要用相同的版本去解释,这也是为什么我用myeclipse10的时候编译和解释后再tomcat中发布老是说我的编译没有通过的原因。
让它与项目的编译器版本设置保持一致即可。
查看项目的编译器版本。
这就是myeclipse10中查看版本编译
没想到这细节在这个myeclipse10里面需要这么去注意。另外就是JDK的版本需要我们默认的设置成我们自己安装的,不然,一导入项目就会是IDE自带的,用惯了2014,这些细节还是有差别的。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/rentian1/article/details/52774662
文章标签: myeclipse
个人分类: web
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

myeclipse10下 Java compiler level does not match解决方法

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭