Tallest Cow 贪心

问题 G: Tallest Cow

时间限制: 1 Sec  内存限制: 128 MB
提交: 31  解决: 17
[提交] [状态] [讨论版] [命题人:admin]

题目描述

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

 

输入

Line 1: Four space-separated integers: N, I, H and R 
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

 

输出

Lines 1..N: Line i contains the maximum possible height of cow i.

 

样例输入

9 3 5 5
1 3
5 3
4 3
3 7
9 8

 

样例输出

5
4
5
3
4
4
5
5
5

第a个牛可以看见第b个牛,因为要求最大高度,所以只要a到b之间的牛的高度都减一即可

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxx=1e4+100;
const int INF=1e9;
const int MOD=1e8;
struct node
{
    int a,b;
}s[maxx];
bool cmp(node x,node y)
{
    if(x.a==y.a)  return x.b<y.b;
    return x.a<y.a;
}
int ans[maxx];
int main()
{
    int n,p,h,m;
    cin>>n>>p>>h>>m;
    for(int i=1; i<=m; i++){
        cin>>s[i].a>>s[i].b;
        if(s[i].a>s[i].b)  swap(s[i].a,s[i].b);
    }
    sort(s+1,s+n+1,cmp);
    s[0].a=0;
    for(int i=1; i<=n; i++){
        if(s[i].a==s[i-1].a && s[i].b==s[i-1].b)  continue;
        ans[s[i].a+1]--;
        ans[s[i].b]++;
    }
    int cnt=0;
    for(int i=1; i<=n; i++){
        cnt+=ans[i];
        cout<<cnt+h<<endl;
    }
    return 0;
}

(线段树不熟练)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我可以帮你解决这个问题。以下是我给出的解决方案: 首先,我们需要定义一个学生类 `Student`,这个类包含身高和体重两个属性: ```python class Student: def __init__(self, height, weight): self.height = height self.weight = weight ``` 然后,我们需要定义一个宿舍类 `Dormitory`,这个类包含宿舍成员列表和一个方法,用于找出宿舍最高的同学: ```python class Dormitory: def __init__(self, max_students=4): self.max_students = max_students self.students = [] def add_student(self, student): if len(self.students) < self.max_students: self.students.append(student) def find_tallest_student(self): tallest = None for student in self.students: if tallest is None or student.height > tallest.height: tallest = student return tallest ``` 最后,我们可以使用这两个类来解决问题。首先,我们需要创建一个宿舍列表,然后向其中添加学生,最后找出每个宿舍最高的同学: ```python dormitories = [Dormitory() for i in range(10)] # 添加学生到宿舍 for i in range(40): student = Student(height=i, weight=i) dormitory = dormitories[i % 10] dormitory.add_student(student) # 找出每个宿舍最高的同学 for dormitory in dormitories: tallest_student = dormitory.find_tallest_student() if tallest_student is not None: print(f"The tallest student in this dormitory is {tallest_student.height}cm tall.") else: print("This dormitory has no students.") ``` 这样,我们就可以找出每个宿舍最高的同学了。希望这个解决方案能够帮助到你。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值