【POJ 1050】To the Max(dp)

43 篇文章 0 订阅
To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47334 Accepted: 25060

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

[题意][求最大和子矩阵]
【题解】【dp】
【前缀和乱搞】(这好像是很久之前写过的题。。。复习下)
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[110][110],a[110][110],f1[110],c[110],n,maxn=-0x7fffffff;
int main()
{
	int i,j,k;
	scanf("%d",&n);
	for (i=1;i<=n;i++)
	 for (j=1;j<=n;j++)
	   scanf("%d",&a[i][j]);
    for (i=1;i<=n;i++)
      f[1][i]=a[1][i];
    for (i=2;i<=n;i++)
      for (j=1;j<=n;j++)
        f[i][j]=f[i-1][j]+a[i][j];//每一列的和 
    for (i=1;i<=n-1;i++)
     for (j=i;j<=n;j++)
       {
       	int sum=-0x7fffffff;
       	for (k=1;k<=n;k++)
       	 c[k]=f[j][k]-f[i][k];//从i到j第k列的和
	    f1[0]=0;
		for (k=1;k<=n;k++)
		  f1[k]=max(f1[k-1]+c[k],c[k]);
		for (k=1;k<=n;k++)
		  sum=max(sum,f1[k]);//当前情况下的最大值 
		maxn=max(maxn,sum);//与之前求的最大矩形对比 
       }
	printf("%d",maxn);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值