Arbitrage

Arbitrage (最短路)

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No

翻译

套利是利用货币汇率的差异将一种货币的一个单位转换成同一种货币的多个单位。例如,假设1美元购买0.5英镑,1英镑购买10.0法国法郎,1法国法郎购买0.21美元。然后,通过转换货币,聪明的交易者可以从1美元开始,购买0.510.00.21=1.05美元,获利5%。

你的工作是写一个程序,以货币汇率表作为输入,然后决定是否可以套利。
输入
输入将包含一个或多个测试用例。在每个测试用例的第一行有一个整数n(1<=n<=30),表示不同货币的数量。接下来的n行中每个行包含一种货币的名称。在名称中不会出现空格。下一行包含一个整数m,表示要跟踪的表的长度。最后的M行分别包含源货币的名称ci、表示从ci到cj汇率的实数rij和目标货币的名称cj。没有出现在表格中的交换是不可能的。
测试用例之间用空行分隔。对于n,输入以零(0)的值终止。
输出
对于每个测试用例,分别以“case case:yes”和“case case:no”的格式打印一行,说明是否可以套利。
样本输入

美元
英国镑
法国法郎

美元0.5英镑
英国镑10.0法国法郎
法国法郎0.21美元


美元
英国镑
法国法郎
6
美元0.5英镑
美元4.9法郎
英国镑10.0法国法郎
英国镑1.99美元
法国法郎0.09英镑
法国法郎0.19美元

0
样品输出
案例1:是的
案例2:否

思路

给出一些货币和货币之间的兑换比率,问是否可以使某种货币经过一些列兑换之后,货币值增加。举例说就是1美元经过一些兑换之后,超过1美元。可以输出Yes,否则输出No。
分析:flyod算法我还不太会,基本上是看着大佬的慢慢敲,还有一个用最短路的和map;

#include<stdio.h>
#include<iostream>
#include<map>
using namespace std;
map<string,int>name;
#define MAXN 30
double g[MAXN][MAXN];
//Floyed算法,求任意两个顶点间的最短路径
//dis[][]记录任意两点间的最短路径,初始的dis[][]记录直接路径 
#define typec double
void floyed(typec dis[][MAXN],int n)//节点从1~n编号
{
    int i,j,k;
    for(k=1;k<=n;k++)
       for(i=1;i<=n;i++)
         for(j=1;j<=n;j++)
             if(dis[i][j]<dis[i][k]*dis[k][j])
                 dis[i][j]=dis[i][k]*dis[k][j];
    
}     
//**********************************************************
int main()
{
    int n,i,m,j;
    string str1,str2;
    double r;
    int iCase=0;
    while(scanf("%d",&n),n)
    {
        iCase++;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&str1);
            name[str1]=i;
        }
        for(i=1;i<=n;i++)
           for(j=1;j<=n;j++)
           {
               if(i==j)g[i][j]=1;
               else g[i][j]=0;
           }    
        scanf("%d",&m);   
        while(m--)
        {
            cin>>str1>>r>>str2;
            g[name[str1]][name[str2]]=r;
        }     
        floyed(g,n);
        bool flag=false;
        for(i=1;i<=n;i++)
          if(g[i][i]>1)
          {flag=true;break;}
        if(flag)  printf("Case %d: Yes\n",iCase);
        else printf("Case %d: No\n",iCase);
    }    
    return 0;
}   
最短路
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
 
const int N = 35;
int n, m;
double  d[N], Map[N][N];
struct A
{
    char name[100];
}a[35];
 
int Find(char *s)
{
    for(int i = 0; i < n; i++)
        if(strcmp(a[i].name, s) == 0)
            return i;
}
 
int SPFA(int start)
{
    queue<int> q;
    bool inq[N];
    for(int i = 0; i < n; i++)
        d[i] = 0;
    memset(inq, 0, sizeof(inq));
    while(!q.empty())
        q.pop();
    d[start] = 1;
    inq[start] = 1;
    q.push(start);
    while(!q.empty())
    {
        int x = q.front(); 
        q.pop();
        inq[x] = false;
        for(int i = 0; i < n; i++)
        {
            if(d[i] < d[x] * Map[x][i])
            {
                d[i] = d[x] * Map[x][i];
                if(d[start] > 1.0)
                    return 1;
                if(!inq[i])
                {
                    inq[i] = true;
                    q.push(i);
                }
            }
        }
    }
    return 0;
}
 
int main()
{
    int i, j, cas = 0;
    char s1[35], s2[35];
    double s;
    while(~scanf("%d",&n) && n)
    {
        for(i = 0; i < n; i++)
        {
            for(j = 0; j < n; j++)
            {
                if(i == j)
                    Map[i][j] = 1;
                else
                    Map[i][j] = 0;
            }
        }
        for(i = 0; i < n; i++)
            scanf("%s",a[i].name);
        scanf("%d",&m);
        for(i = 0; i < m; i++)
        {
            scanf("%s%lf%s",s1, &s, s2);
            int u = Find(s1), v = Find(s2);
            Map[u][v] = s;
        }
        int flag = 0;
        for(i = 0; i < n; i++)
        {
            if(SPFA(i) == 1)
            {
                flag = 1;
                break;
            }
        }
        printf("Case %d: ",++cas);
        printf("%s\n", flag ? "Yes" : "No");
    }
    return 0;
}

原文:https://blog.csdn.net/lyhvoyage/article/details/19248927 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值