题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805422639136768
题目描述
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
输入
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224 ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
输出
For each test case, simply print the dominant color in a line.
样例输入
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
样例输出
24
代码
#include <iostream>
#include <map>
using namespace std;
int main() {
int m, n;
scanf("%d %d", &m, &n);
map<int, int> arr;
int half = m * n / 2;
for(int i = 0; i < n; i++) {
for(int j = 0; j < m; j++) {
int temp;
scanf("%d", &temp);
arr[temp]++;
if(arr[temp] > half) {
printf("%d", temp);
return 0;
}
}
}
return 0;
}