FZU1050 Number lengths(数论,规律,概念)

题目:

 Problem 1050 Number lengths

Accept: 1096    Submit: 2263
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * ... * 2 * 1)

 Input

Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.

 Output

For each value of N, print out how many digits are in N!.

 Sample Input

13 32000

 Sample Output

1 1 130271

思路:

题目的意思是问你一个数的阶乘里面有几位数,以前做水题的时候做过,昨天比赛又遇到了,开一篇博客存一下记录阶乘位数的方法

求一个数阶乘的位数 
可以直接采用log10求一个数阶乘的位数 
N=n! 
方法1 
log10(n!)  
=log10(123n)  
=log10(1)+log10(2)++log10(n)

log10N表示以10为底,N的对数。缩写是lgN.

natural logarithm 自然对数 
natural 英 [‘nætʃ(ə)r(ə)l] 美 [‘nætʃrəl] 
logarithm 英 [‘lɒgərɪð(ə)m; -rɪθ-] 美 [‘lɔɡərɪðəm]


代码:

#include <stdio.h>
#include <string.h>
#include <string>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 100+20
#define M 1000000+10
#define LL long long
using namespace std;
int a[M];
void biao()
{
    double x=1;
    for(int i=1; i<=M; i++)
    {
        x+=log10(double(i));
        a[i]=floor(x);
    }

}
int main()
{

    int n;
    biao();
    while(~scanf("%d",&n))
        printf("%d\n",a[n]);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值