ZOJ3714 Java Beans(水题,滚动数组)

题目:

Java Beans

Time Limit: 2 Seconds       Memory Limit: 65536 KB

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ M ≤ N). Here N and M are defined in above description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input
2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75
Sample Output
16
158

Author:  FAN, Yuzhe
Contest:  The 10th Zhejiang Provincial Collegiate Programming Contest
Submit     Status
思路:

这题的题意很好懂,但是我做的时候在把他连成圈的时候,不知道怎么连,在他的后面又加满了相同的,这样做有点麻烦,在这里改进一下

代码1:(原先的)

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 100000+20
#define mod 10007
#define M 1000000+10
#define LL long long
using namespace std;
int a[1500];
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        int sum=0,num=0;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        int len=200-n;
        for(int i=n;i<=300;i++)
        {
            a[i]=a[i%n];
        }
        for(int i=0;i<n;i++)
        {
            sum=0;
            for(int j=i;j<i+m;j++)
            {

                sum+=a[j];
            }
            num=max(sum,num);
        }
        printf("%d\n",num);
    }
    return 0;
}
代码2(利用滚动数组改进):

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 100000+20
#define mod 10007
#define M 1000000+10
#define LL long long
using namespace std;
int a[1500];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        mem(a,0);
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        int sum=0,num=0;
        if(n==m)
        {
            for(int i=0; i<n; i++)
                num+=a[i];
        }
        else
        {
            for(int i=0; i<n; i++)
            {
                sum=0;
                int cnt=0,j=i;
                while(cnt<m)
                {
                    sum+=a[j++];
                    if(j==n)j=0;
                    cnt++;
                }
                num=max(sum,num);
            }
        }
        printf("%d\n",num);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值