POJ1459 Power Network(多源点网络流,最大流,EK算法)

Description

A power network consists of nodes (power stations, consumers and
dispatchers) connected by power transport lines. A node u may be
supplied with an amount s(u) >= 0 of power, may produce an amount 0 <=
p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <=
min(s(u),cmax(u)) of power, and may deliver an amount
d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0
for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for
any dispatcher. There is at most one power transport line (u,v) from a
node u to a node v in the net; it transports an amount 0 <= l(u,v) <=
lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power
consumed in the net. The problem is to compute the maximum value of
Con.

An example is in figure 1. The label x/y of power station u shows that
p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x
and cmax(u)=y. The label x/y of power transport line (u,v) shows that
l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that
there are other possible states of the network but the value of Con
cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a
power network. It starts with four integers: 0 <= n <= 100 (nodes), 0
<= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <=
n^2 (power transport lines). Follow m data triplets (u,v)z, where u
and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the
value of lmax(u,v). Follow np doublets (u)z, where u is the identifier
of a power station and 0 <= z <= 10000 is the value of pmax(u). The
data set ends with nc doublets (u)z, where u is the identifier of a
consumer and 0 <= z <= 10000 is the value of cmax(u). All input
numbers are integers. Except the (u,v)z triplets and the (u)z
doublets, which do not contain white spaces, white spaces can occur
freely in input. Input data terminate with an end of file and are
correct.

Output

For each data set from the input, the program prints on the standard
output the maximum amount of power that can be consumed in the
corresponding network. Each result has an integral value and is
printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a
network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1
with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and
lmax(1,0)=10. The maximum value of Con is 15. The second data set
encodes the network from figure 1.

思路

这道题是题意杀。

给你n个点,其中有np个是能提供电力的点,nc个是能消费电力的点,剩下的点(n-np-nc)是中转战即不提供电力也不消费电力,点与点之间是有线路存在的,有m条线路,每条线路有最多运载限定。
前4个数据就是有n个点,np个供电点,nc个消费点,m条线路,接来题目先给出的是m条线路的数据,(起点,终点)最多运载量,然后是np个供电点的数据(供电点)最多供电量,接着就是nc个消费点的数据(消费点)最多消费电量。
题目要我们求出给定的图最大能消费的总电量(就是求最大流)

这道题的思想在于转化,我们在发电站前面建一个超级源点,与每一个源点连一条容量为最大负载的边,在用户后面建立一个超级汇点,每一个用户与超级汇点连一条容量为最大接受量的边。然后就是求最大流了。

代码

#include <cstdio>
#include <cstring>
#include <cctype>
#include <stdlib.h>
#include <string>
#include <map>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
const int N=200+20;
int g[N][N],f[N][N],pre[N];//分别代表残余网络,实流网络,前驱数组
bool vis[N];//标记数组
int n,m;//点数和边数
bool bfs(int s,int t)
{
    mem(pre,-1);
    mem(vis,false);
    queue<int>q;
    vis[s]=true;
    q.push(s);
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        for(int i=0; i<=n; i++)
        {
            if(!vis[i]&&g[now][i]>0)
            {
                vis[i]=true;
                pre[i]=now;
                if(i==t)
                    return true;
                q.push(i);
            }
        }
    }
    return false;
}
int EK(int s,int t)
{
    int v,w,d,maxflow=0;
    while(bfs(s,t))
    {
        v=t;
        d=inf;
        while(v!=s)
        {
            w=pre[v];
            d=min(d,g[w][v]);
            v=w;
        }
        maxflow+=d;
        v=t;
        while(v!=s)
        {
            w=pre[v];
            g[w][v]-=d;
            g[v][w]+=d;
            if(f[v][w]>0)
                f[v][w]-=d;
            else
                f[w][v]+=d;
            v=w;
        }
    }
    return maxflow;
}
int main()
{
    int np,nc,a,b,c;
    while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
    {
        mem(g,0);
        while(m--)
        {
            while(getchar()!='(');
            scanf("%d,%d)%d",&a,&b,&c);
            g[a+1][b+1]+=c;
        }
        while(np--)
        {
            while(getchar()!='(');
            scanf("%d)%d",&a,&c);
            g[0][a+1]+=c;
        }
        while(nc--)
        {
            while(getchar()!='(');
            scanf("%d)%d",&a,&c);
            g[a+1][n+1]+=c;
        }
        n++;
        printf("%d\n",EK(0,n));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值