POJ 1459 Power Network (多源点最大流 EK)

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 


An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

 

题目大意

n个点,np个点为供电站,nc个点为耗电站,m条边,给出m条边的信息:(u,v)c(c为流量),和np个供电站的信息:(u)x(x为供电量),和nc个耗电站的信息(u)x(x为耗电量),其余的点不耗电也不供电仅中转。求最大耗电量

思路:
多源点最大流,供电站为源点,耗电站为汇点。建立一个超级源点与供电站相连,流量为供电站的供电量,建立一个超级汇点与耗电站相连,流量为耗电站的耗电量。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
const int inf=0x3f3f3f;
const int N=200+20;
int g[N][N],f[N],pre[N];//g为残余网络量,f为从源点到当前点的最大流量,pre记录路径
int bfs(int s,int t) //找增广路
{
    memset(pre,-1,sizeof(pre));
    queue<int>q;
    f[s]=inf;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        if(u==t) break;
        for(int i=s;i<=t;i++)
            if(i!=s&&g[u][i]>0&&pre[i]==-1)
        {
            pre[i]=u;
            f[i]=min(f[u],g[u][i]);
            q.push(i);
        }
    }
    if(pre[t]==-1) return -1;
    return f[t];
}
int EK(int s,int t)
{
    int d=0,tot=0;
    while(1)
    {
        d=bfs(s,t);
        if(d==-1) break;//如果找不到增广路就结束循环
        int p=t;
        while(p!=s) //更新增广路径的残余网络
        {
            g[pre[p]][p]-=d;
            g[p][pre[p]]+=d;
            p=pre[p];
        }
        tot+=d;
    }
    return tot;
}
int main()
{
   int n,np,nc,m;
   while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
   {
       memset(g,0,sizeof(g));
       memset(f,0,sizeof(f));
       int a,b,c;
       for(int i=0;i<m;i++)
       {
           while(getchar()!='(');
           scanf("%d,%d)%d",&a,&b,&c);
           g[a+1][b+1]+=c;
       }
       for(int i=0;i<np;i++)
       {
           while(getchar()!='(');
           scanf("%d)%d",&a,&b);
           g[0][a+1]+=b; //0为超级源点
       }
       for(int i=0;i<nc;i++)
       {
           while(getchar()!='(');
           scanf("%d)%d",&a,&b);
           g[a+1][n+1]+=b; //n+1为超级汇点
       }
       printf("%d\n",EK(0,n+1));
   }
   return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值