Palindrome POJ - 1159(回文字符串 最长公共子序列 滚动数组)

Palindrome

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input
5
Ab3bd
Sample Output
2

回文是一种对称的字符串,也就是说,从左到右以及从右到左读取相同的字符串。您要编写一个程序,给定一个字符串,该程序确定要插入字符串以获得回文的最小字符数。

例如,通过插入两个字符,字符串“Ab3bd”可以转换为回文(“dAb3bAd”或“Adb3bdA”)。但是,插入少于2个字符不会产生回文。
输入
你的程序是从输入中读取的。第一行包含一个整数:输入字符串的长度N, 3 <= N <= 5000。第二行包含一个长度为n的字符串。字符串由大写字母(从’A’到’Z’)、小写字母(从’A’到’Z’)和数字(从’0’到’9’)组成。大写字母和小写字母被认为是不同的。
输出
输出占一行,它是所需的最小值。

解题思路:
将所给字符串倒着存入一个数组中,然后求出两个字符串的最长共公子序列长度。用字符串长度减去最长共公子序列长度得到的就是能使该字符串成为回文字符串需要的最小插入字符数。
特别注意
由于字符串长度最大为5000,为了避免超出内存,利用滚动数组思想进行优化,压缩节省储存空间。
所以dp数组可以开dp[2][5000]。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[5001],b[5001];
int dp[2][5002];
int main()
{
    int n,i,j;
    while(~scanf("%d",&n))
    {
        j=0;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(dp,0,sizeof(dp));
        scanf("%s",a);
        for(i=0; i<n; i++)
            b[j++]=a[n-1-i];
        for(i=0;i<n;i++)                 //求出a和b数组的最长公共子序列长度
        {
            for(j=0;j<n;j++)
             {
               if(a[i]==b[j])
                dp[(i+1)%2][j+1]=dp[i%2][j]+1;
               else
                dp[(i+1)%2][j+1]=max(dp[i%2][j+1],dp[(i+1)%2][j]);
             }
        }
        printf("%d\n",n-dp[n%2][n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值