Wormholes(Bellman-Ford最短路 模板题)

Wormholes


While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
大意
有个农民他有 n 块田,然后现在给你 m 组田与田之间的距离关系,田与田之间所给出的路径都是双向的,但是有的田里有虫洞。输入数据第一行表示数据的组数第二行分别表示:农田数 正常路径数 虫洞路径数 之后行输入正常路径和虫洞路径。
注意
1.虫洞路径每行第三个数据录入值应该为负值。
2.另外正常路径是双向的
3…虫洞是单向的
(这个题的题意怪怪的,比较难理解。反正我当时是,莫得理解…不过题很单纯,解题方法和Bellman-Ford模板几乎一样(当然,那个双向边一定是要改的))
思路
由于存在着虫洞问题,也可能会包含负权回路。
核心代码:
for(k=n-1;k>=0;k–)//最多执行n-1次
for(i=1;i<=m;i++) //m指边数
if(dis[v[i]]>dis[[u[i]]+w[i])
dis[v[i]]>dis[[u[i]]+w[i]

代码:

#include<stdio.h>
#include<string.h>
int dis[5100],u[5100],v[5100],w[5100];//由于道路的双向性,所以数组上限也*2
int main()
{
    int inf=0x3f3f3f3f;
    int i,j,k,check,flag,n,m,t,m2,c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&m2);

        for(i=1; i<=2*m; i=i+2)   //注意前m条边是双向连通
        {
            scanf("%d%d%d",&u[i],&v[i],&w[i]);
            u[i+1]=v[i];
            v[i+1]=u[i];
            w[i+1]=w[i];
        }
        int x;
        for(i=2*m+1;i<=2*m+m2;i++)  //虫洞是单向
        {
            scanf("%d%d%d",&u[i],&v[i],&x);
            w[i]=-1*x;
        }

        for(i=1; i<=n; i++)  //初始化道路不连通
            dis[i]=inf;
        dis[1]=0;
        for(k=1; k<=n-1; k++)
        {
            check=0;//用来检测本次循环是否松弛
            for(i=1; i<=2*m+m2;i++)
            {
                if(dis[v[i]]>dis[u[i]]+w[i])
                {
                    dis[v[i]]=dis[u[i]]+w[i];
                    check=1;
                }
            }
            if(check==0)break;//若没有则松弛结束
        }
        flag=0;   //判断是否有负权回路
        for(i=1;i<=2*m+m2;i++)
            if(dis[v[i]]>dis[u[i]]+w[i])
                 flag=1;   //最多n-1条边松弛完成后
                            //若还能松弛则存在负权回路
        if(flag==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值