Equations(哈希._.)

Consider equations having the following form:

ax12+b*x22+cx32+d*x42=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
Output
For each test case, output a single line containing the number of the solutions.

Sample Input
1 2 3 -4
1 1 1 1
Sample Output
39088
0

题意: 给你a,b,c,d让你求x1x2x3x4有多少种情况使得下式成立:

解析:一开始肯定想用暴力过,数据小丫,然后超时…意料之中
后来发现,因为有关X的未知量全都是二次方的形式,所以总数应该是假设x全为正数的2^4倍
也就是说x的范围变成了:(0.100]。然后我手痒又试了试暴力,又超时…

最后实在没有思路万万没想到这题时哈希…呵。。。涨姿势了
两个双重for循环

#include<stdio.h>
#include<string.h>
int hash[2000005];
int s[10005];
void memset()
{
    for(int i=0; i<10000; i++)
        hash[s[i]+1000000]=0;
}
int main()
{
    int a,b,c,d,i,j,k,sum;
    while(~scanf("%d%d%d%d",&a,&b,&c,&d))
    {
        sum=0,k=0;;
        if(a>0&&b>0&&c>0&&d>0||a<0&&b<0&&c<0&&d<0)
        {
            printf("0\n");
            continue;
        }
        for(i=1; i<=100; i++)
            for(j=1; j<=100; j++)
            {
                s[k]=a*i*i+b*j*j;
                hash[s[k++]+1000000]++;
            }
        for(i=1; i<=100; ++i)
            for(j=1; j<=100; ++j)
                sum+=hash[1000000-c*i*i-d*j*j];
        printf("%d\n",sum*16);
        memset();
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值