Equations(hash)

Problem Description
Consider equations having the following form: ax12+b*x22+cx32+d*x42=0 a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.Determine how many solutions satisfy the given equation.

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.End of file.

Output
For each test case, output a single line containing the number of the solutions.
Sample Input

1 2 3 -4
1 1 1 1
Sample Output
39088
0

分开两部分求和,若两部分的和是0,则就加上那么多种,最后乘以16。每个解有正有负,结果有2^4种

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
using namespace std;
int s1[1000005];
int s2[1000005];
int main()
{
 int a,b,c,d;
 while(cin>>a>>b>>c>>d)
 {
  if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
        {
            printf("0\n");
            continue;
        }
  memset(s1,0,sizeof(s1));
  memset(s2,0,sizeof(s2));
  for(int i=1;i<=100;i++)
  {
   for(int j=1;j<=100;j++)
   {
    int k=a*i*i+b*j*j;
    if(k>=0)
    s1[k]++;
    else
    s2[-k]++;
   }
  }
  int ans=0;
  for(int i=1;i<=100;i++)
  {
   for(int j=1;j<=100;j++)
   {
    int k=c*i*i+d*j*j;
    if(k>0)
    {
     ans+=s2[k];
    }
    else
    {
     ans+=s1[-k];
    }
   }
  }
  printf("%d\n",ans*16);
 }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值