1126 Eulerian Path (25 分)判断是不是欧拉图

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题意:给出图的点和边的情况,判断是欧拉图,半欧拉图,还是非欧拉图
思路:分两个步骤,第一个用dfs求连通的顶点数是不是等于总顶点数来判断所有顶点是不是连通的,如果不是连通的,直接就是非欧拉图。第二个如果所有顶点的度数都是偶数的并且全部顶点连通,则为欧拉图,如果只有两个顶点度数是奇数,其他顶点度数都是偶数并且全部顶点连通,则为半欧拉图,其余为非欧拉图。
设置一个vector > v来存储所有顶点和边,用vector visit来标记在dfs的时候有没有遍历过顶点。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>

using namespace std;

vector<vector<int> > v;
vector<bool> visit;

//查找连通图的结点个数 (排除掉不是连通图的可能性) 
int count2 = 0;

void dfs(int index) {
	visit[index] = true;
	count2++;
	//这里下标从0开始 
	for(int i = 0;i < v[index].size();i++) {
		if(visit[v[index][i]] == false) {
			dfs(v[index][i]);
		} 
	}
} 

int main() {
	int n,m;
	scanf("%d%d",&n,&m);
	v.resize(n + 1);
	visit.resize(n + 1);
	for(int i = 0;i < m;i++) {
		int a,b;
		scanf("%d%d",&a,&b);
		v[a].push_back(b);
		v[b].push_back(a);
	}
	//纪录偶数的数量 
	int even = 0;
	for(int i = 1;i <= n;i++) {
		if(i != 1) printf(" ");
		if(v[i].size() % 2 == 0) even++;
		printf("%d",v[i].size());
	} 
	printf("\n");
	dfs(1);
	if(even == n && count2 == n) {
		printf("Eulerian");
	} else if(even == n - 2 && count2 == n) {
		printf("Semi-Eulerian");
	} else {
		printf("Non-Eulerian");
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值