1041 Be Unique (20 分) hash输出第一个出现只出现一次的数字

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^​4​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10^5) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题意:输入n个数,输出第一个出现只出现一次的数字,如果没有这些数字,则输出None。
思路:先用vector存储输入的序列,然后再用hash数组来存储这些数字出现的次数,每次都从0循环到n-1即可。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>

using namespace std;

int n;
int hash1[10010];

int main() {
	scanf("%d",&n);
	vector<int> v(n);
	for(int i = 0;i < n;i++) {
		scanf("%d",&v[i]);
	}
	for(int i = 0;i < n;i++) {
		hash1[v[i]]++;
	}
	for(int i = 0;i < n;i++) {
		if(hash1[v[i]] == 1) {
			printf("%d\n",v[i]);
			return 0;
		}
	}
	printf("None\n");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值