ZOJ3819 ACM-ICPC 2014 亚洲区域赛牡丹江赛区现场赛A题 Average Score 签到题

                                           Average Score

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

The next line contains N - 1 integers A1, A2, .., AN-1 representing the scores of other students in Bob's class.

The last line contains M integers B1, B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2 4

 题意:

就是Bob考了一个数学成绩,然后比较差,如果放到自己班的话就会使自己班的平均分变低,放到另一个班的话就会使另一个班的平均分变高,然后求Bob的最大分数和最小分数。

思路:

实际上这道题用自己的分数乘以人数求的就是分数的上下区间,另一个班的平均分可以看做下界,自己班的平均分可以看作上界。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
using namespace std;
int main()
{
 //   freopen("in.txt","r",stdin);
    int t;
    cin>>t;//输入该题的测试组数 
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);//n表示Bob班的人数,m表示其他班的人数 
        int sum1=0,sum2=0;//求和 
        for(int i=0;i<n-1;i++)
        {
            int it;
            scanf("%d",&it);
            sum1+=it;
        }
        for(int i=0;i<m;i++)
        {
            int it;
            scanf("%d",&it);
            sum2+=it;
        }
        int ti=1;
        while(ti*m<=sum2)//当他去其他班的时候其他班的平均分就变高,所以这次Bob的分数是下界 
            ti++;
        int l=ti;
        while(ti*(n-1)<sum1)//当他在自己的班的时候,那么自己班的分数就会变低,所以这次Bob的分数为上界 
            ti++;
        int r=ti-1;
        printf("%d %d\n",l,r);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值