PAT 乙级 1010 (JAVA,随缘C++)

1010 一元多项式求导 (25分)

设计函数求一元多项式的导数。(注:x​n​​(n为整数)的一阶导数为nx​n−1​​。)

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过 1000 的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是 0,但是表示为 0 0

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

第一版:(部分正确)

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main {
	/**
	 * 1010 一元多项式求导 (25分) 设计函数求一元多项式的导数。(注:x ​n ​​ (n为整数)的一阶导数为nx ​n−1 ​​ 。)
	 * 
	 * 输入格式: 以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过 1000 的整数)。数字间以空格分隔。
	 * 
	 * 输出格式: 以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是 0,但是表示为
	 * 0 0。
	 * 
	 * 输入样例: 3 4 -5 2 6 1 -2 0 输出样例: 12 3 -10 1 6 0
	 * 
	 */
	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		String nextLine = scanner.nextLine();
		String[] split = nextLine.split(" ");
		Integer[] intArray = new Integer[split.length];
		List<Integer> arrayList = new ArrayList<Integer>();
		for (int i = 0; i < split.length; i++) {
			intArray[i] = Integer.parseInt(split[i].trim());
		}
		for (int i = 0; i < intArray.length; i = i + 2) {
			if (i == 0 && intArray[i + 1] == 0) {
				arrayList.add(0);
				arrayList.add(0);
			}
			int sum = intArray[i] * intArray[i + 1];
			if (sum == 0) {
				continue;
			}
			arrayList.add(sum);
			if (intArray[i + 1] - 1 >= 0) {
				arrayList.add(intArray[i + 1] - 1);
			}

		}
		for (int i = 0; i < arrayList.size(); i++) {
			if (i == arrayList.size() - 1) {
				System.out.print(arrayList.get(i));
			} else {
				System.out.print(arrayList.get(i) + " ");
			}
		}
	}
}

这个是应该是漏了系数为0的条件

他人版本:

第一版:(C++)

#include <iostream>
using namespace std;
int main() {
    int a, b, flag = 0;
    while (cin >> a >> b) {
        if (b != 0) {
            if (flag == 1) cout << " ";
            cout << a * b << " " << b - 1;
            flag = 1;
        }
    }
    if (flag == 0) cout << "0 0";
    return 0;
}

第二版:(JAVA)

import java.util.Scanner;
 
public class Main {
 
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String input = sc.nextLine();
		String[] split = input.split("\\s+");
		StringBuffer result = new StringBuffer();
		for(int i = 0;i<split.length;i+=2){
 
			//系数非0指数为0
			if(Integer.parseInt(split[i+1]) == 0 && Integer.parseInt(split[i]) != 0 ){
				continue;
			}
 
			//系数为0
			if(Integer.parseInt(split[i]) == 0){
				result.append(0+" ");
				result.append(0+" ");
				continue;
			}
 
			//普通情况
			result.append(Integer.parseInt(split[i])*Integer.parseInt(split[i+1])+" "+(Integer.parseInt(split[i+1])-1)+" ");
		}
		if(result.length() == 0){//空串时输出0 0
			System.out.println("0 0");
		}else{
			System.out.println(result.substring(0, result.length()-1));
		}
	}
}
 
 
 
 
 
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值