简单计算器

简单计算器 (20 分)
模拟简单运算器的工作。假设计算器只能进行加减乘除运算,运算数和结果都是整数,四种运算符的优先级相同,按从左到右的顺序计算。

输入格式:
输入在一行中给出一个四则运算算式,没有空格,且至少有一个操作数。遇等号”=”说明输入结束。

输出格式:
在一行中输出算式的运算结果,或者如果除法分母为0或有非法运算符,则输出错误信息“ERROR”。

输入样例:
1+2*10-10/2=
输出样例:
10

#include<iostream>
#include<cstring>
#include<string>

using namespace std;

bool IsNum(char c){
	if(c>='0' && c<='9'){
		return true;
	}
	return false;
}
bool stand(char c){
	if(c=='+' || c=='-' || c=='*' || c=='/'){
		return true;
	}
	return false;
}
int count(int num,int res,char sign){
	
	if(sign=='+'){
		res += num;
	}else if(sign=='-'){
		res -= num;
	}else if(sign=='*'){
		res *= num;
	}else if(sign=='/'){
		if(num!=0){
			res /= num;
		}
	}
	return res;
}
int main(){
	char c,str[1000];
	char sign='+'; 
	int num=0,res=0;
	int flag=1;
	int i,len;
	cin>>str;
	len = strlen(str);
	for(i=0;i<len;i++){
		c = str[i];
		if(c=='='){
			if(num==0 && sign=='/'){
				flag=-1;
				break;
			}else{
				res = count(num,res,sign);
			}
			break;
		}
		if(!IsNum(c) && !stand(c)){
			flag=-1;
			break;
		}
		if(IsNum(c)){
			num = num*10 + c-'0';
		} 
		if(stand(c)){
			if(num==0 && sign=='/'){
				flag=-1;
				break;
			}else{
				res = count(num,res,sign);
				sign = c;
			}
			num=0;
		}
	} 
	if(flag==-1){
		cout<<"ERROR";
	}else{
		cout<<res;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值