POJ 1300 Door Man 欧拉回路的判定

Door Man
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2503 Accepted: 1011

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you: 

  1. Always shut open doors behind you immediately after passing through 
  2. Never open a closed door 
  3. End up in your chambers (room 0) with all doors closed 

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible. 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 
A single data set has 3 components: 

  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20). 
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors! 
  3. End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT". 

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

这是一道关于欧拉回路判定的题目,可以看出给出的图是无向图,那么怎么判断无向图是否是欧拉回路呢?在这说几点,当然前提是图是联通的。第一种情况:如果每个点的都是偶度节点,那么这个图肯定是欧拉图(包含欧拉回路);第二种情况:如果图中有奇度节点,如果有两个奇度节点,其他节点都是偶度节点,那么该图存在欧拉通路,并且路的两端肯定是这两个点。其他节点都不存在欧拉回路或者欧拉通路。也就是说以上说的就是无向联通图存在欧拉回路或者欧拉通路的充分必要条件。

那么这道题就是简单的欧拉回路判定了,直接贴出代码:

#include <iostream>
#include <algorithm>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <vector>
#include <cctype>
using namespace std;

int door[25];//用来记录每个点的度数
char s[200+10];//用于读取信息

int main()
{
//    freopen("s","r",stdin);

    int n,m;
    while(gets(s))
    {
        if(!strcmp(s,"ENDOFINPUT"))     break;//结束程序

        memset(door,0,sizeof(door));//初始化
        int doors=0;//记录走过的门数

        if(s[0]=='S')
        {
            sscanf(s,"%*s%d%d",&m,&n);

            for(int i=0;i<n;i++)
            {
                gets(s);
                for(int j=0;j<strlen(s);j++)
                    if(isdigit(s[j]))
                    {
                        door[i]++;
                        door[s[j]-'0']++;
                        doors++;
                    }
            }
        }

        int odd=0,even=0;

        for(int i=0;i<n;i++)
        {
            if(door[i]%2==0)    even++;
            else    odd++;
        }
        //欧拉图的判定
        if(odd==0&&m==0)    printf("YES %d\n",doors);
        else if(odd==2&&(door[m]&1)&&(door[0]&1)&&m!=0)
            printf("YES %d\n",doors);
        else    printf("NO\n");

        gets(s);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值