POJ1300 欧拉回路 解题报告

Door Man

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc…). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you:
Always shut open doors behind you immediately after passing through
Never open a closed door
End up in your chambers (room 0) with all doors closed
In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:
Start line - A single line, “START M N”, where M indicates the butler’s starting room, and N indicates the number of rooms in the house (1 <= N <= 20).
Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read “5 7”. The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors!
End line - A single line, “END”
Following the final data set will be a single line, “ENDOFINPUT”.
Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line “YES X”, where X is the number of doors he closed. Otherwise, print “NO”.

Sample Input

START 1 2
1
END
START 0 5
1 2 2 3 3 4 4
END
START 0 10
1 9
2
3
4
5
6
7
8
9
END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

【解题报告】
题目描述:
你是一座大庄园的管家。庄园有很多房间,编号为0、1、2、3,…。你的主人是一个心不在焉的人,经常沿着走廊随意地把房间的门打开。多年来,你掌握了一个诀窍:沿着一个通道,穿过这些大房间,并把房门关上。你的问题是能否找到一条路径经过所有开着门的房间,并使得:
1) 通过门后立即把门关上;
2) 关上了的门不再打开;
3) 最后回到你自己的房间(房间0),并且所有的门都已经关闭了。
在本题中,给定房间列表,及连通房间的、开着的门,并给定一个起始房间,判断是否存在这样的一条路径。不需要输出这样的路径,只需判断是否存在。假定任意两个房间之间都是连通的(可能需要经过其他房间)。
输入描述:
输入文件包含多个(最多可达100 个)测试数据,每个测试数据之间没有空行隔开。
每个测试数据包括3 部分:
起始行-格式为“START M N”,其中M 为管理员起始所处的房间号,N 为房间的总数(1≤N≤20);
房间列表-一共N 行,每行列出了一个房间通向其他房间的房间号(只需列出比它的号码大的房间号,可能有多个,按升序排列),比如房间3 有门通向房间1、5、7,则房间3 的信息行内容为“5 7”,第一行代表房间0,最后一行代表行间N-1。有可能有些行为空行,当然最后一行肯定是空行,因为N-1 是最大的房间号;两个房间之间可能有多扇门连通。终止行-内容为”END”。
输入文件最后一行是”ENDOFINPUT”,表示输入结束。
输出描述:
每个测试数据对应一行输出,如果能找到一条路关闭所有的门,并且回到房间0,则输出”YES
X”,X 是他关闭的门的总数,否则输出”NO”。

分析:
以房间为顶点、连接房间之间的门为边构造图。根据题目的意思,输入文件中每个测试数据所构造的图都是连通的。本题实际上是判断一个图中是否存在欧拉回路或欧拉通路,要分两种情况考虑:
1) 如果所有的房间都有偶数个门(通往其他房间),那么有欧拉回路,可以从0 号房间出发,回到0 号房间。但是这种情况下,出发的房间必须为0,因为要求回到0 号房间。例如,第1 个测试数据所对应的图为图5.6(a),图中有浅色阴影的顶点(即顶点0),表示管家初始时所处的房间;在该测试数据中,管家可以回到0 号房间。
2) 有两个房间的门数为奇数,其余的都是偶数,如果出发的房间和0 号房间的门数都是奇数,那么也可以从出发的房间到达0 号房间,并且满足题目要求。但是不能从房间0 出发,必须从另一个门数为奇数的房间出发。例如第2、3 个测试数据就是这种情形,对应的图为图(b)和图(c),输出的结果分别是”NO”和”YES 7”。对于庄园的其他情形,都是不能完成题目中所要求的任务的,所以直接输出”NO”。
本题的难点在于输入数据的处理:可以使用sscanf函数处理数据。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define M 202  
#define INF 100000001   
typedef long long ll;  
int main()  
{  
    char a[M];  
    int m,n;  
    while(scanf("%s",a))  
    {  
        if(strcmp(a,"ENDOFINPUT")==0) break;  
        scanf("%d%d",&m,&n);  
        int door[101]={0},i,j,num=0,odd=0;getchar();  
        for(i=0;i<n;i++)  
        {  
            int k=0;  
            gets(a);  
            while(sscanf(a+k,"%d",&j)==1) 
            {  
                num++;  
                door[i]++; door[j]++;  
                while(a[k]&&a[k]==' ') k++;  
                while(a[k]&&a[k]!=' ') k++;  
            }  
        }  
        scanf("%s",a);
        for(i=0;i<n;i++)  
        {  
            if(door[i]&1) odd++;   
        }  
        if(odd==0&&m==0) printf("YES %d\n",num); 
        else if(odd==2&&door[m]&1&&door[0]&1&&m!=0)  
            printf("YES %d\n",num);  
        else printf("NO\n"); 
    }  
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值