ZOJ 3432  Find the Lost Sock

Time Limit: 2000MSMemory Limit: 65536K64bit IO Format: %lld & %llu

[Submit  [Go Back  [Status]

Description

Alice bought a lot of pairs of socks yesterday. But when she went home, she found that she has lost one of them. Each sock has a name which contains exactly 7 charaters.

ZOJ <wbr>3432 <wbr> <wbr>Find <wbr>the <wbr>Lost <wbr>Sock

Alice wants to know which sock she has lost. Maybe you can help her.

Input

There are multiple cases. The first line containing an integer n (1 <= n <= 1000000) indicates that Alice bought n pairs of socks. For the following 2*n-1 lines, each line is a string with 7 charaters indicating the name of the socks that Alice took back.

Output

The name of the lost sock.

Sample Input

2
aabcdef
bzyxwvu
bzyxwvu
4
aqwerty
eas fgh
aqwerty
easdfgh
easdfgh
aqwerty
aqwerty
2
0x0abcd
0ABCDEF
0x0abcd

Sample Output

aabcdef
eas fgh
0ABCDEF
Hint

Because of HUGE input, scanf is recommended.  

这题一般的解法基本都会超时的,所以不要想暴力解决,刚开学的时候学了个异或运算,没想到竟然也能用上了,呵呵(袜子真的挺好看的!)

代码:

#include<stdio.h>

#include<string.h>

int num[8];

char s[8];

int main()

{

int n,i,k;

while(scanf("%d",&n)!=EOF)

{

getchar();

memset(num,0,sizeof(num));

k=0;

n=n*2-2;

gets(s);

for(i=0;i<7;i++)

{

k=s[i];

num[i]=k;

}

while(n--)

{

gets(s);

for(i=0;i<7;i++)

{

k=s[i];

num[i]=num[i]^k;

}

}

for(k=0;k<7;k++)

printf("%c",num[k]);

printf("\n");

}

return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值