ZCMU1416

1416: Find the Lost Sock

Time Limit: 2 Sec   Memory Limit: 128 MB
Submit: 344   Solved: 74
[ Submit][ Status][ Web Board]

Description

Alice bought a lot of pairs of socks yesterday. But when she went home, she found that she has lost one of them. Each sock has a name which contains exactly 7 charaters.

Alice wants to know which sock she has lost. Maybe you can help her.

Input

There are multiple cases. The first line containing an integer n (1 <= n <= 1000000) indicates that Alice bought n pairs of socks. For the following 2*n-1 lines, each line  is a string with 7 charaters indicating the name of the socks that Alice took back.

Output

The name of the lost sock.

Sample Input

2aabcdefbzyxwvubzyxwvu4aqwertyeasafghaqwertyeasdfgheasdfghaqwertyaqwerty20x0abcd0ABCDEF0x0abcd

Sample Output

aabcdefeasafgh0ABCDEF
#include<stdio.h>
#include<string.h>
int main()
{
   int a[8];
   char s[8];
   int n,i,k;
   while(~scanf("%d",&n))
   {
       getchar();
       memset(a,0,sizeof(a));
       for(int i=1;i<=2*n-1;i++)
       {
           scanf("%s",s);//注意这里不能用getchar读入,不然会报输出超限,可能是它读到了EOF
           for(int j=0;j<7;j++)
           {
              a[j]^=s[j];
           }
       }
       for(int i=0;i<7;i++)
        printf("%c",a[i]);
        printf("\n");
   }
    return 0;
}


题意:给你一系列字符串,让你输出出现奇数次的字符串,找丢失的袜子,袜子不都是成双的嘛...

直接做肯定得炸呀,看了大佬的方法,用异或解决


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值