ZZULI_TEAM_PRACTICE(1)  HDU 1212…

Time Limit: 1000MSMemory Limit: 32768KB64bit IO Format: %I64d & %I64u

[Submit  [Go Back  [Status]

Description

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output

For each test case, you have to ouput the result of A mod B.
 

Sample Input

2 3 
12 7 
152455856554521 3250
 

Sample Output

1521
取模运算,大整数除以小整数,简单,不解释
代码:
C语言临时自用代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int  main()
{
        char  str [ 1008 ];
        int  i , len , m ,n [ 1008 ];
        while( scanf( "%s %d" , str , & m) != EOF)
        {
                memset(n , 0 , sizeof(n));
                for( i = 0; str [ i ]; i ++)
                      n [ i ] = str [ i ] - '0';
                len = i;
                for( i = 0; i < len - 1; i ++)
                        if(n [ i ] < m)
                              n [ i + 1 ] +=n [ i ] * 10;
                        else {
                              n [ i ] =n [ i ] % m;
                              n [ i + 1 ] +=n [ i ] * 10;
                        }
                printf( "%d \n " ,n [ i ] % m);
        }
        return  0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值