ZZULI 1596 Assign the task(暴力…

Assign the task

Time Limit:1000MS  Memory Limit:65536K
Total Submit:20 Accepted:6

Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.
For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1 <= u,v <= N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1 <= x <= N,0 <= y <= 10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
C 3 
T 3 2 
C 3

Sample Output

Case #1:
-1 
1 
2

Source

 

这题本来不想写解题报告的,因为自己的方法实在是太烂了,数据稍微强一点就不过,但是看在自己为这道题纠结了这么长时间的份上不写又对不起自己的代码,所以还是写上吧,纪念一下ZZULI <wbr>1596 <wbr>Assign <wbr>the <wbr>task(暴力水过鈥︹Γ

 

题意:一个公司,一个老板(这个貌似是废话啊),每个人都有一个boss,但是一个boss可能有好多的下属,现在给一个人一个任务,那么这个人的所有下属都要放下手头的任务去完成这个任务,求给若干个人若干个任务之后某个人的任务是什么

 

这道题猛一看好像是直接建立一个树然后就可简单了,但是我一看到数据范围的时候傻眼了,n<=50000,坑爹啊,这得开多大的空间啊,果断放弃这个方法,后来想想还是用暴力试试吧,因为一个人只能有一个boss嘛,然后就记下这个人的boss就好了,然后当给定一个任务的时候就寻找每个人的所有上级,看看是不是那个人的任务,如果是的话就把他的任务重新赋值,就这样,水过了……

 

代码:

#include<stdio.h>
#include<stdlib.h>
int sum [ 50006 ], num [ 50006 ];
int main (){
              int i , x , y , j , a;
              int T ,n , m , flag;
              char C [ 10 ];
              scanf( "%d" , & T);
              for( flag = 1; flag <= T; flag ++ ){
                              scanf( "%d" , &n);
                              for( i = 1; i <=n; i ++ ){
                                              num [ i ] =- 1;
                                              sum [ i ] = i;
                              }
                              for( i = 0; i <n - 1; i ++ ){
                                              scanf( "%d%d" , & x , & y);
                                              sum [ x ] = y;
                              }
                              printf( "Case #%d: \n " , flag);
                              scanf( "%d" , & m);
                              for( i = 0; i < m; i ++ ){
                                              scanf( "%s" , C);
                                              if( C [ 0 ] == 'C' ){
                                                              scanf( "%d" , & x);
                                                              printf( "%d \n " , num [ x ]);
                                              }
                                              else if( C [ 0 ] == 'T' ){
                                                              scanf( "%d%d" , & x , & y);
                                                              num [ x ] = y;
                                                              for( j = 1; j <=n; j ++ ){
                                                                              a = j;
                                                                              while( sum [ a ] != a ){
                                                                                              if( a == x)
                                                                                                              break;
                                                                                              a = sum [ a ];
                                                                              }
                                                                              if( a == x)
                                                                                              num [ j ] = y;
                                                              }
                                              }
                              }
              }
              return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值