ZZULI 1599(POJ 1975)Median Wei…

Median Weight Bead
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 2182Accepted: 1076

Description

There are N beads which of the same shape and size, but with different weights. N is an odd number and the beads are labeled as 1, 2, ..., N. Your task is to find the bead whose weight is median (the ((N+1)/2)th among all beads). The following comparison has been performed on some pairs of beads:
A scale is given to compare the weights of beads. We can determine which one is heavier than the other between two beads. As the result, we now know that some beads are heavier than others. We are going to remove some beads which cannot have the medium weight.

For example, the following results show which bead is heavier after M comparisons where M=4 and N=5.
1.   Bead 2 is heavier than Bead 1.

2. Bead 4 is heavier than Bead 3.
3. Bead 5 is heavier than Bead 1.
4. Bead 4 is heavier than Bead 2.

From the above results, though we cannot determine exactly which is the median bead, we know that Bead 1 and Bead 4 can never have the median weight: Beads 2, 4, 5 are heavier than Bead 1, and Beads 1, 2, 3 are lighter than Bead 4. Therefore, we can remove these two beads.

Write a program to count the number of beads which cannot have the median weight.

Input

The first line of the input file contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:
The first line of input data contains an integer N (1 <= N <= 99) denoting the number of beads, and M denoting the number of pairs of beads compared. In each of the next M lines, two numbers are given where the first bead is heavier than the second bead.

Output

There should be one line per test case. Print the number of beads which can never have the medium weight.

Sample Input

1
5 4
2 1
4 3
5 1
4 2

Sample Output

2

Source

 
这题虽然是Floyd,可是我怎么看怎么都有种暴力的感觉,16MS水过……
 
题意:给一组数据,表示前面的大于后面的,然后如果从小到大排列的话第(n+1)/2个就是中间数,现在问根据数据有几个不可能是中间数
 
这题猛一看貌似挺简单的,可是真去实现的时候却又无从下手了(好纠结啊),赛后看了人家的才知道是Floyd算法,于是搜索各种解题报告啊,然后在各种纠结下看懂了怎么做的了,不会的参考Floyd算法……
 
代码:
 
  
#include<stdio.h>
#include<string.h>
int main()
{
      int light [ 100 ][ 100 ], weight [ 100 ][ 100 ], i , j , k , m ,n , a ,b , Case;
      int ans1 , ans2 , num;
      scanf( "%d" , & Case);
      while( Case -- ){
              scanf( "%d%d" , &n , & m);
              memset( light , 0 , sizeof( light));
              memset( weight , 0 , sizeof( weight));
              for( i = 0; i < m; i ++ ){
                      scanf( "%d%d" , & a , &b);
                      light [ a ][b ] = 1;
                      weight [b ][ a ] = 1;
              }

              for( k = 1; k <=n; k ++)
                      for( i = 1; i <=n; i ++)
                              for( j = 1; j <=n; j ++)
                              {
                                      if( light [ i ][ k ] && light [ k ][ j ])
                                              light [ i ][ j ] = 1;
                                      if( weight [ i ][ k ] && weight [ k ][ j ])
                                              weight [ i ][ j ] = 1;
                              }
              num = 0;
              for( i = 1; i <=n; i ++)
              {
                      ans1 = 0; ans2 = 0;
                      for( j = 1; j <=n; j ++)
                      {
                              if( light [ i ][ j ])
                                      ans1 ++;
                              if( weight [ i ][ j ])
                                      ans2 ++;
                      }
                      if( ans1 >=(n + 1) / 2)
                              num ++;
                      if( ans2 >=(n + 1) / 2)
                              num ++;
              }
              printf( "%d \n " , num);
      }
      return 0;
}
 
PS:原来的三重循环是按照先i后j然后k循环的,但是提交WA,至今还没有理解,哪位大牛知道了麻烦给留个言ZZULI <wbr>1599(POJ <wbr>1975)Median <wbr>Weight <wbr>Bead(Floyd水过鈥︹Γ
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值