hdu1005

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 157703    Accepted Submission(s): 38622


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5



题意  给出递推式
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

由于内存与时间限制 我们无法使用O(n)的递推方式求解

这种取余数的题很可能与循环节有关联,在做题时多手动算一算或写大暴力算法检验一下


那么思考题干

答案最终对7取模。即为0----6的数。对于固定的AB  f[n]可能的取值只有49种,由于以1,1开头。当循环中再次出现1,1时,出现循环。程序寻找下次1,1出现的位置。剩下的就很显然了


java源代码

package sduoj无限滚动;
import java.util.Scanner;
import java.math.*;
public class haaha
{
    public static void main(String args[])
    {
        Scanner s=new Scanner(System.in);
        int[] ans=new int[1000];
        boolean flag=true;
        while (flag)
        {
            int ff=1,gg=0;
            int a=s.nextInt();
            int b=s.nextInt();
            int n=s.nextInt();
            if(a==0) System.exit(-1);
            ans[1]=1;ans[2]=1;
            int i;
            for (i=3;i<=n;i++)
            {
                ans[i]=((a*ans[i-1])%7+(b*ans[i-2])%7)%7;
                if ((ans[i]==1)&&(ans[i-1]==1)) break;
            }
            gg=n%(i);
            if (gg==0) System.out.println(ans[ff-2]);
            else System.out.println(ans[n]);
        }
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值