PAT 1038 Recover the Smallest Number (30)

22 篇文章 0 订阅
12 篇文章 0 订阅

1038 Recover the Smallest Number (30)(30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10^​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

思路:

字符串排序,一开始是自己手写了一个比较函数,后来在网上的题解里看到了一个很巧的比较函数,就果断的吸收过来了。因为要最后组成的数字最小,那么就需要越靠前的数字越小,对两个将要比较的字符串来说,就是要a+b<b+a。输出的时候要把前缀的0去掉,需要注意的是整个字符串全是0的情况下要输出一个0。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

bool cmp(const string &a, const string &b)
{
	return a + b < b + a;
}

int main()
{
	int n;
	cin >> n;
	vector<string> v(n);
	for (int i = 0; i < n; i++)
		cin >> v[i];
	sort(v.begin(), v.end(), cmp);
	string ans = "";
	for (int i = 0; i < v.size(); i++)
		ans += v[i];
	bool flag = false;
	for (int i = 0; i < ans.length(); i++)
	{
		if (ans[i] != '0')
			flag = true;
		if (flag)
			cout << ans[i];
	}
	if (!flag)
		cout << 0;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值