1038 Recover the Smallest Number (30 分)

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

呃呃呃呃呃以前写过,但是感觉自己还是不开窍 直接比较字符串a+b和b+a哪个比较小即可

代码:

#include<bits/stdc++.h>
using namespace std;
vector<string>vec;
bool cmp(string a, string b){
	return a + b < b + a;
}
int main()
{
	int n;
	scanf("%d", &n);
	char str[10];
	for(int i = 0 ; i < n ; i ++)
	{
		scanf("%s",str);
		vec.push_back(str);
	}
	sort(vec.begin(), vec.end(), cmp);
	string s = "",t = "";
	for(int i = 0 ; i < vec.size(); i ++)
		s += vec[i];
	while(s.empty() == 0 && s.at(0) == '0')
		s.replace(0,1,"");
	if(s.empty() == true)
		cout<<0<<endl;
	else 
		cout<<s<<endl;
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值