PAT 1044 Shopping in Mars (25)

22 篇文章 0 订阅
2 篇文章 0 订阅

1044 Shopping in Mars (25)(25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10^5​​), the total number of diamonds on the chain, and M (≤10^8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯DN​​ (Di≤10^3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of ij such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of ij such that Di + ... + Dj > M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

思路:

网上题解里面大多是二分和尺取法,我这里是枚举加一点点优化,也可以全部通过。先用前缀和sum[i]求出从到第i个数的和,枚举起点i和终点j,i到j的和就可以表示为sum[j]-sum[i-1]。 如果找到等于m的组,就直接输出,如果没有找到等于m的组就把略大一点的组存到vector里面,按照值和起点排序再输出。优化就是每次找到一组后,用k来记录当前的j,下次的终点枚举从k开始。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

struct pairs
{
	int from, to;
	int value;
};

vector<pairs> a;  //存放略大于m一点的组
int sum[100005] = { 0 };

bool cmp(const pairs &a, const pairs &b)
{
	if (a.value != b.value)
		return a.value < b.value;
	else
		return a.from < b.from;
}

int main()
{
	int n, m;
	scanf("%d%d", &n, &m);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d", &sum[i]);
		sum[i] += sum[i - 1];
	}
	bool flag = false;
	int k = 1;
	for (int i = 1; i <= n; i++)
	{
		for (int j = k; j <= n; j++)
		{
			if (sum[j] - sum[i - 1] == m)
			{
				flag = true;
				printf("%d-%d\n", i, j);
				k = j;
				break;
			}
			if(!flag)
			{
				if (sum[j] - sum[i - 1] > m)
				{
					pairs p;
					p.from = i;
					p.to = j;
					p.value = sum[j] - sum[i - 1];
					a.push_back(p);
					k = j;
					break;
				}
			}
		}
		if (sum[n] - sum[i - 1] < m)
			break;
	}
	if(!flag)
	{
		sort(a.begin(), a.end(), cmp);
		int v = a[0].value;
		for (int i = 0; i < a.size(); i++)
		{
			if (a[i].value == v)
				printf("%d-%d\n", a[i].from, a[i].to);
			else
				break;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值